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Chapter 1: Introduction to 
Commence Workgroup
Welcome to Commence Workgroup®, from Commence Corporation. Commence 
Workgroup allows users to communicate and share information with other workgroup users 

on a network, whether they are local or remote to the server. Private information can be 
maintained which remains local to a client PC. While individual users benefit from the 
powerful capabilities of Commence to maintain calendars, address books, notes, phone 

and letter logs, and much more, Workgroup users can extend this power over a network 
and share information and work with other members of a team or work force.

Commence Workgroup’s networking capabilities allow users to share and periodically 
synchronize database information with the server using either a Local Area Network (LAN), 

a compatible Windows e–mail program, or the Internet via an Internet Service Provider 
(ISP) or dedicated Internet connection. Users on multiple PCs can share information from 
the same databases, viewing and updating information simultaneously. They may also 

define private information that other users are unable to see or access. Different levels of 
authorization can be defined to control various access privileges.

Commence uses a distributed database architecture in which each client of a workgroup 
has its own local copy of the shared database. This arrangement has many advantages, 

including:

• Users can use a local copy of the shared database off–line.  While connected to the LAN, data 
is automatically synchronized with all other users on the network. When disconnected, Commence 
remembers the changes that have been made. Later, when remote users connect to the network, the 
changes and updates that have been made are automatically synchronized with other users, thereby 
keeping all data in sync. This has the added advantage of allowing users to continue using 
Commence, even when the network is down. Those who synchronize via e–mail will continue to 
communicate their changes to the server as long as they can send and receive e–mail. Similarly, 
users who synchronize using an Internet connection will continue synchronizing as long as the 
Internet connection is intact.

• There is no data locking, so all information is available at all times, authorizations 
permitting.  Some workgroup products lock records as they are being viewed making them 
unavailable to other users. With Commence, each user’s local database is always available. 

• Users can create private information that remains in the local copy of the shared database.  
Private (or local) information does not synchronize with the server nor with any other user within the 
workgroup, thereby protecting each user’s private information.

The Components of a Workgroup
A Workgroup consists of a Server and one or more Clients. Each of these components is 

described in the following paragraphs.
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The Commence 
Server

The primary component of a Workgroup is the Server. The Server software is installed 
by the Commence Administrator onto a PC that is designated to be the Commence 

Server. It is from the Server that the Commence Administrator configures and assigns 
permissions, configures Client and Server communications, and registers Clients.

Additionally, the Commence Server maintains the shared database. Since Commence 
uses a distributed database architecture, the Server acts as a hub for all database 

changes that are made by users. If a user adds or edits an item, this change will 
synchronize to the server (via the shared LAN directory, e–mail, or the Internet), at which 
point the server will synchronize the change(s) to other users who have appropriate 

access privileges.

Commence Clients After the Server has been installed and the shared database set up, users can enroll in 
the Shared Database. Each user is referred to as a Client. As a Client, each user will 
receive a copy of the Shared Database, now called a Client Database. The Client 

Database is similar to the Shared Database, but, depending upon the Client’s permis-
sions, it may include all or only part of the Shared Database. Clients then access the 
Client Database just as they would any other Commence database. As changes are 

made, they will synchronize with the Server Database, and then to other Client 
Databases which have appropriate access privileges. Since Commence is a distributed 
database, a user can disconnect from the network and still use the Client Database. 

When they re–connect with the LAN, e–mail system, or Internet, all changes that have 
been made to either the Client or Server will automatically synchronize. 

For a graphical representation of a simple Workgroup, see the following figure.

Figure 1-1: Commence workgroup
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Introduction to Commence Workgroup: The Components of a Workgroup
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The Role of the Administrator
The Commence Administrator is responsible for the following activities:

• installing the Commence Server

• setting up the shared database

• entering and maintaining user information

• helping users set up and enroll in the shared database

• ensuring the shared database is available and actively synchronizing user data

• auditing database activity

• performing regular database backups

• troubleshooting any problems

The Administrator should have a good knowledge of how to use Commence, the network, 
and optionally the Internet or e–mail package installed on the system.

The Commence Administrator helps users set up Client Databases, as well as answers 

questions or solves problems encountered while installing, enrolling, or using the Commence 
Client. Additionally, the Administrator should troubleshoot any data synchronization problems 
or problems encountered using shared definitions or items.

About this Manual
This manual is intended to assist a Commence Administrator in the installation, configu-

ration, and maintenance of a Commence Workgroup. The manual is organized so that a new 
Administrator will be able to methodically step through the process of installing and config-
uring a Workgroup. This is achieved by dedicating separate Chapters to each step of the 

process. The Appendices at the rear of the book provide information which will prove useful 
to both the new and experienced Administrator.

Proceed to Chapter 2: Installing a Commence Server  to begin setting up the workgroup 
server.
Introduction to Commence Workgroup: The Role of the Administrator
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Chapter 2: Installing a 
Commence Server
What Is Needed to Run A Commence Server
To run a Commence Workgroup, there must be a copy of the Server version of 

Commence Workgroup installed and running on a Windows system. In addition, each user 

must have a licensed Client.

The hardware needed to run the Commence Server should have a 1GHz processor and 
must be running a supported version of Windows. See “System Requirements for Server” 
on page 6. System requirements vary slightly depending on which version of Windows is in 

use.

To use Commence Workgroup on a local area network, the LAN configuration must 
provide a shared file system and support Windows–compatible workstations for 
Commence clients and the Commence server. 

If the Commence Server software is installed to a shared network directory, the 

Commence Server PC requires Read–Write–Create-Delete-Modify  access to this 
directory and all of its subdirectories. Clients should be granted Read–Only  access to the 
server program directory to prevent users from inadvertently modifying the server files.

If an e–mail package is used to synchronize the Commence workgroup, it must be a 

Windows–based electronic mail package that supports either a VIM, MAPI, or CMC 
messaging interface. E–mail packages that can be used for Commence synchronization 

include Lotus NotesTM and Microsoft OutlookTM as well as some versions of Outlook 

Express. 

The Workgroup Expert is an administration tool that sends daily status reports to the 
Commence workgroup administrator. The Workgroup Expert works with either an SMTP e-
mail server or any 32-bit MAPI e-mail package.

If the Internet is used to synchronize the Commence Workgroup, appropriate Internet 

software must be available and running. Additionally, an Internet FTP directory must be 
created to which all Clients have full access. It is in this Internet FTP directory that sync 
files will be maintained until no longer needed.

Basic 
Requirements

The minimum memory requirements listed provide a baseline for running Commence on 

each operating system without any additional software. However the recommended guide-
lines should be followed to allow for integration with Microsoft Office, e-mail and fax 
software, as well as running additional applications in the background.
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What the Installation Does
When the Commence Server is installed, several things are accomplished:

• The Commence program (EXE) is uncompressed and installed to the Commence program 
directory.

• The License Administration program  (License) is uncompressed and installed.

• The Commence Administration program  (ComAdmin) is uncompressed and installed in a 
subdirectory of the Commence program directory.

• The Commence RM Workgroup Administration Files  (WGFILES8 directory), are installed in a 
subdirectory of the Application Data directory.

• The Contact Manager , if selected, is uncompressed and installed in a subdirectory of the Appli-
cation Data directory. The Contact Manager is also added to the list of shared databases in 
ComAdmin.

• The Tutorial database , if selected, is uncompressed and installed in a subdirectory of the Appli-
cation Data directory. The Tutorial database contains sample data in the Commence Contact 
Manager applications, including examples that take advantage of the new features in Commence 
RM.

• Word processor macros , if selected, are installed to the appropriate folder for your word 
processor. Note the 32-bit version of Microsoft Word must be installed in advance.

• Commence Connect for E-Mail , if selected, is uncompressed and installed to the Commence 
program directory. The document library is installed in a subdirectory of the Application Data 
directory. Connect simplifies E-Mail marketing campaign delivery and literature fulfillment 

Table 2-1: System Requirements for  Server

Operat ing System

Any of  the fo l lowing:

• Windows 8, Windows 8.1

• Windows 7

• Windows Vista™

• Windows 2003® Server

• Microsoft® Windows XP Professional

Hardware & Memory

Recommended:

• 1GB hard drive with at least 300 MB free 
(your OS may require more)

• 1.5 GHz or higher processor with 512 MB 
RAM

Minimum:

• 1 GHz processor with 256 MB RAM

Network

any network that  prov ides a shared 
f i le  system and suppor ts  Windows–
compat ib le workstat ions for  
Commence c l ients  and the Commence 
server

Other Hardware

• CD ROM drive

• a Windows supported pointing device is 
highly recommended but not required
Installing a Commence Server: What the Installation Does
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to your Commence contacts.

• Shortcuts to Commence documentation  including this manual, the Server Guide, are placed on the 
Start menu.

• Other components, if not found on the PC, are installed to the Commence program directory and to 
the Windows system folders as needed. Such components include ActiveX Controls (OCX), Windows 
Telephony (TAPI) and several Dynamic Link Libraries (DLLs).

Installing a new Server
The first step when establishing a Commence Workgroup is to install the Server Software. 

Any PC connected to a Local Area Network (LAN) or the Internet can be used as the 
Commence Server.

When selecting the server system, consider that the Commence server software should be 
running at all times for automatic synchronization to occur. If the system is shut down or if 

the shared database is closed, synchronization will halt until the Commence server is 
brought back online. For this reason, a desktop is a better choice for a server than a portable 
laptop.

Since the Commence Server is the hub for all data changes within the Workgroup, frequent 

synchronization activity may momentarily prevent a Commence user from accessing the 
shared database on the server. For this reason, it is recommended that a dedicated Windows 
system be used to run the Commence Server.

After you have reviewed the basic server requirements, select the computer which will be 

designated as the Commence Server. From this machine, click on the Commence Server  
button to begin installation of the Server software.

The Network Tools  button will also appear as one of the installation options and may only 
be installed on the designated Commence Server computer. By clicking on this button you 

will begin the installation of the Workgroup Expert software. This software is used to monitor 
the synchronization performance of the Commence Server and associated Clients.

Note: The Workgroup Expert software can be installed later after you have configured the Commence 
server for synchronization. Use of the Workgroup Expert software requires a MAPI 32-bit or SMTP E-
mail application. Please review the “Workgroup Expert Guide” for more information on installation and 
configuration of this software. To access this guide, click on the “View Documentation” button.

The Commence RM  button also appears as one of the network installation options. This is 
used to install the software on each client workstation.

Default Installation Perform the following procedure to install the Commence RM Server:

1 Choose one workstation with continuous network access to run the Commence Server software.

2 Insert the Commence RM compact disc into the CD-ROM drive of this PC. The compact disc will 
start automatically and the Commence RM installation screen will appear.

3 Click Network Install  to select which software to install.

4 Select Commence Server  to begin the server installation.

5 The Software License Agreement will be displayed. If you agree to abide by the terms of the licence 
agreement click Yes to continue. Clicking No will cancel the setup operation .

6 You will be prompted to enter your user Information. You must enter a valid Commence RM serial 

Network Insta l l

Commence Server

Network Tools

Commence RM
Installing a Commence Server: Installing a new Server
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number in the box labeled Serial: . This number can be found on the CD sleeve. After all the 
information is correctly entered, click Next , then click Yes to confirm your registration infor-
mation.

7 Select Next . Follow the remaining instructions on the screen to complete the installation.

License 
Administration 
and Activation

The Commence server is initially configured for a single user. Follow the License 

Administration steps below to set the total number of users in the workgroup.

This must be done before continuing with the remaining steps of the upgrade process.

1 At the conclusion of the Server installation the program will prompt you for an Authorization Key. 
Enter the key printed on the Server Authorization document included with your package then 
click OK.

2 The license program will then contact the Commence Corporation servers to verify your Serial 
Number and Authorization Key. Click Yes to proceed. Note an internet connection is required. 

3 When the activation is complete a confirmation message will display the number of available 
user licenses for this workgroup installation. Click Yes to confirm the user limit.

4 If the license was updated successfully, simply click OK to close the message window.

The first step (i.e. the server installation) is now complete. If you are configuring a new 
workgroup or if you have increased the number of users in your workgroup, proceed to 

Chapter 3: Server Administration . This chapter discusses how to use the ComAdmin 
software. This add-on utility is installed with Commence and is used to configure the 
usernames and passwords for the workgroup and to manage the shared database. The 

Contact Manager is the default shared database that was added during installation. You 
can use this database or add your own custom database.

Upgrading a Server from prior versions of Commence
 Upon opening the Server database, Commence will determine if the database can be 

converted. The conversion process will first backup the database then convert it to the 
new format. Commence Clients may continue to use their local executable and DLL files, 

and will be able to open their Client Databases. However synchronization will be disabled 
until the Client is upgraded and the client database is converted to the same format as 
the Commence Server. Click any topic below for more details.

• “Sync All Clients with the Server” on page 9

• “Disable Syncing at the Client Workstation(s)” on page 9

• “Clear the sync directory” on page 9

• “Backup all Shared Databases at the Commence Server” on page 10

• “Shut Down the Commence Server” on page 10

• “Run ComAdmin” on page 10

• “Backup every Client Database” on page 10

• “Upgrade the Commence Server” on page 10

• “License Administration and Activation” on page 11

• “Install Workgroup Expert” on page 11

• “Exit the CD Browser” on page 11
Installing a Commence Server: Upgrading a Server from prior versions of Commence
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• “Run ComAdmin” on page 11

• “Launch the Commence Server” on page 11

• “Upgrade Client Workstations” on page 11

These steps assure that the existing workgroup is taken offline in an orderly manner, and 
that no loss of data occurs during the process. The upgrade procedure outlined in the 
following sections is necessary when upgrading from Commence RM 2.1 and earlier versions 

that require a data conversion.

Sync All Clients 
with the Server

Before upgrading the clients, verify that all clients within the workgroup are able to 
synchronize with the Server. If unsure as to the last time a sync occurred between one or 
more clients and the Server, a sync may be forced by using the Home -> Workgroup Sync  

command at each client workstation. It is not necessary to ensure that every client is 
completely up-to-date. Any updates that have not yet been sent up to the server can be 
synchronized later in the new version.

Caution: If the client synchronization does not complete successfully and results in an error message, 
be sure to contact Technical Support to troubleshoot the errors before installing the upgrade. If 
upgrading from Commence RM 2.1 and prior versions, data loss will occur unless all synchronization 
errors are resolved.

Disable Syncing at 
the Client 
Workstation(s)

After each client workstation has successfully synchronized with the Server, syncing should 
be disabled at the client workstations. Perform the following procedure to disable syncing at 

each Client Workstation:

1 Select the Customize -> Workgroup  command from the Menu Bar of the client database.

2 Verify that the Communicate with Server using: radio button is set to the correct method of 
synchronization for the client. The choices are E–Mail , Shared LAN directory , or Internet FTP 
directory .

3 Click OK.

Note: If the Client synchronizes via E–Mail, a second window will be displayed indicating current 
configuration for e–mail addresses.   Click OK.

4 Change the Check every:  sync interval to zero (0) seconds for Shared LAN directory synchroniza-
tions, and zero (0) minutes for e-mail or FTP synchronizations.

5 Click OK. A message box will be displayed indicating that the automatic sync feature for the client 
workstation has been disabled.

6 Click OK.

Clear the sync 
directory

After synchronization has been disabled at each Client Workstation, take a few moments to 
remove all pending synchronization packets from the communication directory. Search the 

shared LAN directory and the FTP directory for all files ending with .UP or .DWN or .TMP and 
delete these. These files cannot be converted to the new data format and will have to be 
recreated in the new version.
Installing a Commence Server: Upgrading a Server from prior versions of Commence
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Backup all Shared 
Databases at the 
Commence Server

It is important to backup all server program files and data files prior to beginning any 
upgrade. If a problem occurs during the upgrade process, the original files may be 

restored from the backups. An external backup utility, such as Microsoft Backup, may be 
used to backup the entire Commence folder. If space permits, you may opt to make a full 
copy of the Commence folder saved to a different drive.

The Commence Backup command is run by clicking the Commence Application button   -> 
Open/Manage Database -> Backup . This can be used to backup just the Server Database 
directory and the wgfiles* folder. 

Shut Down the 
Commence Server

Select the Commence Application button   -> Exit  to close the Commence Server after all 
or most of the pending updates (*.UP files) have been received and accepted by the 

Server and the Workgroup is fully synchronized.

Run ComAdmin Once the Commence Server is closed, this is a good time to verify the Administrator 
login and password. Also take a few moments to update your users list as needed.

Note: Before starting any upgrade procedure, verify that the Password for the Admin  login ID for 
ComAdmin is available. If not, ComAdmin  will not be able to convert the admin data files, and the 
upgrade will not be complete.

To run the Commence Administration software, follow the steps in the section titled 
“Launch ComAdmin” on page 18. 

Select the Users  button  from the ComAdmin menu. Verify that the number of users 

listed does not exceed the User Limit. This limit is displayed by selecting Help  -> 
About...  from the Menu Bar. The administrator (admin) user can be excluded when 
figuring the total number of users. 

If there are more users than allowed, an error will be displayed when you attempt to 

launch the Commence server after the upgrade. Commence will not run until the 
additional users are removed. See “Deleting a User” on page 62. Once you have 
confirmed the Users list is correct, exit from ComAdmin.

Backup every 
Client Database

The Commence Backup command, select the Commence Application button   -> Open/
Manage Database -> Backup , can be used to backup the Client Database. 

Upgrade the 
Commence Server

Install Commence RM on the Commence server PC. This will overwrite the Commence 

executable and DLL files for the previous version.

1 Follow the steps in the section titled “Installing a new Server” on page 7. 

2 Take special note of the Setup Type screen when it appears. The installer will detect if a prior 
version of Commence is installed, and set the Destination Directory to be the same as your 
existing Commence program directory. Do not change this directory . Otherwise Commence 
will not be able to convert your Commence program and data files.

3 Follow the remaining on-screen instructions, clicking Next  after each step. Press Finish  to 
complete the installation.
Installing a Commence Server: Upgrading a Server from prior versions of Commence
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License 
Administration 
and Activation

Immediately after installing the server, the License Administration program will ask you for 
an Authorization Key. The key is printed on the Server Authorization document included with 

your package. This step allows you to properly set the total number of users in the 
workgroup. This step must be done whenever you receive a new serial number for your 
Commence server.

The license program will then contact the Commence Corporation servers to verify your 

Serial Number and Authorization Key. When the activation is complete a confirmation 
message will display the number of available user licenses for this workgroup installation.

Note: If the Commence server does not have a connection to the Internet, the software cannot be 
activated online. To activate the Commence Server via phone contact Commence Corporation to speak 
with a customer service representative.

This must be done before continuing with the remaining steps of the upgrade process. You 
will not be able to run Commence RM until you have successfully completed the license 

administration. See “Launch the License Administration Program” on page 17.

Install Workgroup 
Expert

Commence RM comes with an updated version of the Workgroup Expert synchronization 
monitoring tool designed specifically for this version of Commence. Follow the installation 
steps in the Workgroup Expert User’s Guide to setup this utility. If a previous version of the 

Workgroup Expert was installed on the Commence Server PC, you may upgrade the existing 
installation by overwriting the Workgroup Expert program directory with the new version.

Exit the CD 
Browser

When you are finished installing all the necessary software, click Exit  to close the CD. You 
may safely remove the Commence RM CD from the CD ROM Drive at any time now.

Run ComAdmin Immediately after upgrading to a new version of Commence Workgroup, it is crucial that 
you launch the Commence Administration software to complete the upgrade. 

To run the Commence Administration software, follow the steps in the section titled 

“Launch ComAdmin” on page 18. 

When ComAdmin is run for the first time after upgrading, the existing Commence admin 
data files are copied and converted. The converted files are placed in the WGFILES8 
directory. The Commence Server will require Read–Write–Create-Delete-Modify  access to this 

new shared directory. It is not necessary for client workstations to have any access to the 
WGFILES8  directory.

Launch the 
Commence Server

 Verify you are logged in to Windows as the Administrator. Then start Commence RM and 
open the Commence server database. Follow the steps in the section titled “Launch the 

Server” on page 21. Open the shared database to convert the data to Commence RM.

Upgrade Client 
Workstations

Install Commence RM on the Commence client PC’s. Perform the procedure outlined in the 
Getting Started Guide to install each Commence Client. When the CD browser appears, 
choose Network Install  then select Commence RM  to begin the client installation.
Installing a Commence Server: Upgrading a Server from prior versions of Commence
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Note: Existing Clients will not need to re–enroll after installing the upgrade. However, any Sync 
Link remote databases will have to be recreated using an initial sync file.

Check for Updates
Commence incorporates an update facility that checks for new program updates and 

installs them for you. Keeping up with software enhancements throughout the year can 
now be handled quickly and efficiently. 

Whenever a new update is released it is not necessary for the Commence Adminis-
trator to visit each client workstation with a CD. Simply notify each user via e-mail that a 

new update is ready to download. Clients need only use the Check for Updates  command 
in Commence to launch the auto update feature. 

via Internet Obtaining the latest update is easy when an Internet connection is available on all 
clients. 

• Use the Check For Updates  command on the Commence server to download and install the 
update. See “Administrator tasks” on page 12.

• Notify all Commence users that a new update is available.

• Clients can then update their workstation using the Check For Updates  command. See “Client 
tasks” on page 13.

%Tip Clients can check for updates at their convenience but may forget to do so. The Admin-

istrator can quickly verify all users have applied the update by reviewing the Workgroup 
Expert report. The report will identify which clients are not running the same version as 
the Server.

Commence will need to be closed and restarted when applying updates so be sure to 

save your work before starting the update.

Administrator 
tasks

Prepare the Commence server system as you normally would for a system upgrade, 
then apply the update at the server. The first few steps below are not required but are 
recommended best practices for updating your Commence server.

Note: The update typically affects program files only and not the database. If you are not sure you 
have a current backup, use the  Open/Manage Database  command under the Commence Appli-
cation button  to make a new backup of the Server database. 

1 Use the Help -> System Information  command in Commence to verify the system resources 
are not low. If the system has not been rebooted recently, close and restart Windows.

2 Run Commence and open the Server database. 

3 Use the View -> Close All  command in the Window group to close all views and reports in 
Commence.

4 Select Help -> Check For Updates .

5 Select the Download and Install Update  option.

6 When the Commence Update window opens click Next  to determine if any new files are 
available.
Installing a Commence Server: Check for Updates
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7 Follow the on-screen prompts to complete the installation.

Client tasks To run the update at a client workstation:

1 Close Microsoft Outlook and any other Microsoft Office applications.

2 Save and close all open forms if any data modifications were in progress.

3 Use the View -> Close All  command in the Window group to close all views and reports in 
Commence.

4 Select Help -> Check For Updates .

5 When the Commence Update window opens click Next  to determine if any new files are available.

6 Follow the on-screen prompts to complete the installation.

Note: Users should have Windows Administrator rights to ensure the update is installed properly.

Intranet Updates
If an Internet connection is not readily available to the Commence clients, the administrator 

can download the updates at the Commence Server and distribute the files to all clients via 
an intranet location. A one-time configuration change at the server is all that’s needed to 

redirect clients to this new location. 

A summary of steps is as follows:

• Use the Check For Updates  command on the Commence server to download the update. The 
downloaded file can be copied to your intranet location. See “Download update for intranet distribution” 
on page 13.

• Modify the configuration file, CmcUpdt.INI, for intranet distribution. Allow enough time for this file to 
synchronize to all users. Those who have not received the localized configuration file will require an 
Internet connection to install the update. See “Configuration file for intranet distribution” on page 14.

• Modify the xml file, Commence_update.xml, for intranet distribution. See “Configuring XML file for 
intranet distribution” on page 16.

• Use the Check For Updates  command on the Commence server to download and install the update. 
See “Administrator tasks” on page 12.

• Notify all Commence users that a new update is available.

• Clients can then update their workstation using the Check For Updates  command. See “Client tasks” 
on page 13.

Download update 
for intranet 
distribution

Each time a new update becomes available, the Commence administrator must download 
this file and post it to the local intranet before clients can apply the update.

Note: An Internet connection is still required at the Commence Server to download the update file. The 
clients will just need access to the local intranet.

To obtain the latest update file:

1 Select Help -> Check For Updates  at the Commence Server.

2 Choose to Download Update  then click OK to continue.
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Figure 2-2: Update options

3 The next screen gives you an opportunity to choose where the file will be stored. The 
Commence update file is normally saved to the Application Data Directory. Use the Select 
Directory  button to choose a different location or to create a new folder. Click OK to continue.

Figure 2-3: Save update file to local directory for intranet distribution

4 Click Next  to determine if any new files are available for download. 

5 Follow the on-screen prompts to complete the download.

6 Copy the downloaded file(s) to the designated intranet location. Overwrite any existing update 
files.

Configuration file 
for intranet 
distribution

The steps below will reconfigure the Check For Updates feature for intranet distri-
bution. These steps only need to be performed once. This assumes the same intranet 

folder will be used every time an update is released.

The Commence administrator will need to determine the following paths at the 
Commence server:

• The Application Data directory can be found by selecting Help -> System Information , then 
display Directory Information .

• The Admin Path can be determined by selecting Help -> System Information , then display 
Workgroup Information .

• Use the Save to File  button to create a report of all system paths. Then open the commence.txt 
Installing a Commence Server: Intranet Updates
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file in the program directory to view the system report.

Once you have gathered all the information above you may proceed with the steps below.

1 Close the Commence Server database.

2 Locate the configuration file named "CMCUPDT.INI" in the Application Data directory. 

3 Copy the configuration file to the Admin Path (WGFILES8 folder) on the Commence server machine. 
This folder will also be located in the Application Data directory. 

4 Edit the copy of the CMCUPDT.INI file in the WGFILES8 folder using any text editor. A sample is 
shown below.

Figure 2-4: Configuration file used by the Commence Server to get Internet updates

5 Note the URL setting that directs the Update feature to the commence.com site (e.g. http://
mail.commence.com/updates/Commence_update.xml). This setting directs the Commence instal-
lation to the Internet for it’s updates.

6 Using Internet Explorer, browse to the the Internet URL address you noted in the CMCUPDT.INI file. 
Download a copy of the Commence_update.XML file from the Internet site and save it to the intranet 
location of your choice.

Note: Confirm the Commence_update.XML file is present in your intranet folder before proceeding to 
the next section. See “Configuring XML file for intranet distribution” on page 16.

7 Continue editing the CMCUPDT.INI file.  Change the URL setting to use the same intranet location. 
This is the intranet directory from which clients will download all updates. In the example shown 
below, replace <MY DOMAIN> with the IP Address or domain name of your intranet (e.g., http://
myintranet/Commence/). This is the designated intranet location where all update files will be stored. 

Figure 2-5: Sample changes to configuration file

8 Save the modified CMCUPDT.INI file.

9 Open the Commence Server database. Select Customize -> Workgroup , click Next then click 
Finish .

10 The URL setting from the modified configuration file will be copied to each client the next time they 
synchronize with the server.
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Configuring XML 
file for intranet 
distribution

The steps below will reconfigure the Commence_update.xml file for intranet distri-
bution. These steps only need to be performed once. This assumes the same intranet 

folder will be used every time an update is released.

1 Locate the Commence_update.xml file in your intranet location.

2 Edit the Commence_update.xml file using a text or xml editor.

3 Change the CONSTANT value to use the intranet location where all update files are stored.  Be 
sure to change only the "value=" statement that indicates the update file location (e.g., http://
mail.commence.com/updates/new ). A sample is shown below.

Figure 2-6: CONSTANT value to change in Commence_update.xml

4 Save the modified Commence_update.xml file.

Update the server The update can now be installed on the Commence Server. See “Administrator tasks” 

on page 12. Note the server will still be downloading the update from the Internet 
location, not the local intranet.

Client tasks for 
intranet update

Once the Commence Administrator has reconfigured the Update feature to use the 
local intranet, clients must synchronize with the server to receive the modified configu-

ration file. This file will automatically be sent to all clients during their regular data 
exchange with the Commence workgroup server. Aside from this normal sync 
requirement no special instructions are needed.

The procedure for applying the update at the Commence client workstations is the 

same regardless of the method of distribution. See “Client tasks” on page 13.
Installing a Commence Server: Intranet Updates
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Chapter 3: Server 
Administration
The first step in setting up a Commence Workgroup is administering the shared 
database. This process is managed through two specialized programs included with 
Commence called License  and ComAdmin  (short for Commence Administration.)

Launch the License Administration Program
The first step that must be completed after installing Commence RM Workgroup is to set 

the total number of users that will be accessing the shared database. The License Admin-

istration program is launched automatically after installing the Commence Server. If 
additional client licenses are purchased, the License Administration program must be run 
manually to set the new user limit.

1 From the Windows desktop, select Start  -> All Programs  -> Commence RM 5.0 Workgroup

2 Right click on License  then choose Run As Administrator .

3 The License Dialog Box will be displayed. Your Name, Company Name, and Server serial # 
should already be filled in. This information is gathered from the values you entered during the 
Commence RM Workgroup installation. You may correct these values as needed.

Figure 3-1: License dialog box

4 In the box labeled Authorization Key:  enter the key printed on the Server Authorization 
document.
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Note: The Authorization Key is based on the serial number. Be sure to enter the same serial 
number that you received with the product.

5 Click OK.

6  You will be prompted to activate the product over the Internet. Click Yes to continue.

The current user limit will be increased to match the total number of user licenses you 

purchased.

Launch ComAdmin
Once the total number of licenses has been set, perform the following procedure to 

launch ComAdmin :

1 From the Windows desktop, select Start  -> All Programs  -> Commence RM 5.0 Workgroup -> 
ComAdmin . The Login Dialog Box will be displayed.

2 Login as follows:

• Login ID  - enter admin .

• Password  - leave blank; do not type anything into this space.

Caution: The admin  Login ID is typically reserved for use by the Administrator of the Workgroup. 
By design, this login ID initially does not have a password assigned. For Workgroup Security 
purposes, it is strongly recommended that a password immediately be assigned. Refer to the next 
section, Assign an Administrator Password , for complete instructions.

3 Click OK. The ComAdmin Main Menu screen will be displayed. 

Figure 3-2: ComAdmin main menu

It is from this Main Menu that many of the parameters are accessed and configured.
Server Administration: Launch ComAdmin
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Assign an Administrator Password
Before proceeding with configuring the Commence Server, it is critical to maintain the 

security of the Workgroup. By assigning a password to the admin  Login ID, it assures that 
only authorized persons will have access to vital configuration parameters. Once a 

Workgroup has been established, having an unauthorized person access these parameters 
could result in a failure of the Workgroup and/or loss of critical data.

Perform the following procedure to assign a password to admin :

1 Press the Users   button from the ComAdmin main menu or select File  -> Users  from the 
ComAdmin Menu Bar. The Users Dialog Box will be displayed. 

2 From the Users Dialog Box, highlight Administrator (admin). Click Edit .

3 Enter the desired password in the Password  field.

Note: To help maintain security, when typing in the desired password, each character will be displayed 
as an asterisk (*) in the Password  field as well as the Verify Password  field. For example, if the string 
ABC123DEF  were typed into each field, ********* would actually be displayed.

4 Enter the desired password again in the Verify Password  field.

5 Click OK.

It will now be required to enter the password whenever the Administrator uses the admin  

Login ID. It is strongly suggested that the password be stored in a secure location in the 
event it is forgotten or is needed by another person authorized to login with the admin  Login 
ID.

Proceed with the next section, Add Users, to continue configuring the Commence 

Workgroup Server.

Add Users
Each user of Commence Workgroup must be added before they can access the Shared 

Database.

Note: Each Commence Server limits the number of Clients it can service. This limit can be found in the 
About Dialog Box for ComAdmin. Select Help  -> About  from the Menu Bar. Although the number of 
Client Licenses and Users that can be added is limited to that shown, the Commence Server Edition 
may be easily upgraded to accommodate more clients as required. Contact your vendor for information 
about increasing the number of clients permitted by the Commence Server.

Perform the following procedure to add users to a Commence Workgroup:

1 Select the Users  button,  from the ComAdmin main menu. The Users Dialog Box will be 
displayed.

2 Select Add . The Add User Dialog Box will be displayed.

3 Enter the information for the first user as follows:
Server Administration: Assign an Administrator Password
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Note: As soon as a change is made in any of these fields, the button labeled OK is replaced with 
two (2) buttons labeled Save and Cancel .

• Enter the new user’s full name  - Type in the first name and last name of the user that is being 
added.

• Enter the new user’s login ID  - Type in the Login ID that is to be used when logging into the 
Commence Workgroup. This is typically the user’s initials, their first name, last name, or any combi-
nation of this information. It is recommended that each user’s Login ID be set to the same ID they 
use for logging into the network in order to make it easier to remember.

Note: A User Password is not required. If a password is not to be assigned for a user, leave the 
corresponding two fields in the Add User Dialog Box blank and proceed with step 4 below.

• Enter the new user’s Password  - [OPTIONAL] If used, this is the password that must be 
entered whenever the user opens the database. Requiring the user to logon with a password 
provides an added level of security to the shared database.

• Verify Password  - [OPTIONAL] If a Password is assigned, this is used to verify that the correct 
password has been entered by the user.

4 When all user information is entered correctly, click on Save. After the information for each User 
is saved, an empty Add User Dialog Box continues to be displayed, and the Save and Cancel  
buttons revert to a single OK button. Refer to step 2 above.

5 Repeat steps 3 and 4 for each additional User that is to be added.

6 When all Users have been added, click on OK.

7 The Users Dialog Box is again displayed, showing all users that have just been added.

8 Click OK.

Proceed with the following section, Set Up a Shared Database, to continue configuring 
the Commence Workgroup Server.

Set Up a Shared Database
The basis for any Commence Workgroup is a Shared Database, which is defined using 

ComAdmin . Whether creating a new database from scratch, or converting an existing 
stand–alone database to a Shared Database, the database will need to be added via 

ComAdmin .

Perform the following procedure to add a Shared Database:

1 Select the Databases button,  from the ComAdmin main menu. The Database Dialog Box 
will be displayed. 

2 Select the Add  button. The Add Shared Database Dialog Box will be displayed.

3 Complete the information for the new database as follows:

• Name - the name of the new Shared Database

• Description  - [OPTIONAL] description of the information to be maintained within the new Shared 
Database.

• Database Location  - the path to the database that will become the Server Database. Enter the 
path to an existing database that is to become shared. The path can point to a location on a local 
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drive of the Server PC. If uncertain of the exact path, click Select , and navigate to the desired location.

4 When all information is complete, select OK.

5 Commence will display the following messages:

• If promoting an existing standalone database to a server database, Commence will ask if it should be 
made Shared. Select Yes.

• Commence will ask if an entry for the new database is to be added to the Commence Database List. 
Select No if the database is already available in the Open/Manage Database  menu command in 
Commence. If you select Yes, the database name and location will be added to Commence.

Note: If the database is already available in Commence, say No to this prompt. This will prevent a 
duplicate entry from being added.

6 The new database will be shown in the Database Dialog Box.

7 To add additional shared databases to the Server, repeat steps 2 through 4.

8 When all databases have been added, click OK.

9 Click Exit Program   to exit ComAdmin.

Once the database has been promoted to a Server, the following steps must be taken in 
order to provide a user with access to the information:

• Configure client permissions

• Configure communications parameters

• Register clients

Launch the Server
Before any configuring of the shared database can begin, the Commence Server must be 

running and the Shared Database must be open.

Note: The following procedures assume that the Server was installed using the default path values. If 
the Server was installed in a location other than the default location, some the menu selections 
indicated will need to be modified.

Perform the following procedure to start the Server:

1 From the Start  Menu, select All Programs  -> Commence RM 5.0 Workgroup  -> Commence 
Workgroup .

2 If Commence does not open in the shared database, select the Commence Application button  -> 
Open/Manage Database  and open the desired database.

If more than one shared database is available, each database must be opened using a 
separate copy of Commence. See “Running Multiple Commence Instances” on page 65.

Note: The server MUST be running the shared database in order for any client to enroll or to have any 
synchronization occur.
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After the Server has been successfully started and the Shared Database opened, the 

next step is to establish what the permissions are to be for a newly added User. Proceed 
to the next chapter, “Configure the Client Permissions” on page 23, to continue setting up 
the Commence Workgroup.
Server Administration: Launch the Server
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Chapter 4: Configure the Client 
Permissions
The Commence Server can control what information each user is able to view and modify 
within a Shared Database. There are two levels of permissions that can be configured.

• User Level  - defines whether users can access the shared database.

• Permissions  - define how users can access data in each shared category or desktop. Permis-
sions can be assigned for all items in the category or Selective Permissions can be used to define 
access on a per–item basis within the category.

All users are assigned the default category permissions for any new shared categories 
added to the database. The permissions for any new category may then be modified as 
necessary to allow the information to be accessed as required.

The following sections describe each permission level as well as how to implement 

Selective Permissions.

User Levels
User Levels control which users can enroll to a Shared Database, as well as which users 

are able to change the Shared objects in that database. An object is any one of the 
following:

Category, Connection, Agent, Detail Form, Color Code, Letter Template, Import/Export 
Template, View, or Desktop.

One of three (3) User Levels may be defined as the default for the Shared Database. 

These User Levels are:

• Author  - can access the Shared Database, and add, edit, and delete shared definitions.

• User  - can access the Shared Database, but cannot add, edit, and delete shared definitions. Most 
users will have this user level.

• None  - cannot access the Shared Database. This will prevent any new users from being registered 
and enrolled to the shared database. Access must then be granted on a per–user basis via the 
Permissions dialog box.

Each of these User Levels may be assigned on a per–user basis.

Permissions

Category 
Permissions

Category Permissions determine whether shared items in each category can be viewed, 

modified, or deleted for each shared category within a Shared Database. 

• Read Permission  - determines whether shared items can be viewed for the selected categories.
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• Write Permission  - determines whether shared items can be added or modified in the selected 
categories.

• Delete Permission  - determines whether shared items can be deleted from the selected 
categories.

For each permission, the following choices determine how items in the selected 

categories are handled:

• All  - All items in the category are synchronized to the user.

• Selective  - A subset of items in the category is synchronized to the user.

• None  - No items in the category are synchronized to the user. The user receives an empty 
category.

These permissions can be assigned as a default for all users or on a per–user basis.

Note: Category Permissions do not affect access to local data. So granting a user None or 
Selective category permissions does not prevent a user from adding and modifying local data in 
that category. Any changes made by a user to non-shared items would not synchronize and would 
only affect their local Client Database.

Desktop 
Permissions

Desktop Permissions allow you to control which shared desktops will synchronize to 
each user. When setting desktop permissions, only the Read Permissions can be 
controlled; write and delete permissions do not apply to desktops. Shared desktops can 

be modified and deleted by users who have been granted Author level access.

For each shared desktop within a Shared Database, the following read permissions 
may be assigned.

• All  - This translates to full read (R) permission to the desktop. The desktop in its entirety will 
synchronize to the selected user(s).

• None  - The desktop will not synchronize to the selected user(s). 

These permissions can be assigned as a default for all users or on a per–user basis. 

Set Default Permissions
 Initially, the Default Permissions for a shared database are set to User for the User 

Level and All for category and desktop Permissions. However, these Default Permissions 
may be modified to satisfy specific needs. If the Default Permissions are to remain 
unchanged, proceed directly to the next chapter “Configure Communication Settings” on 

page 31 to continue configuring the Commence Server.

Perform the following procedure to set the Default Permissions assigned to new clients:

1 Verify that the Commence Server is running, and the desired Shared Database is active.

2 Select Customize  -> Workgroup  from the Menu Bar. The Customize Workgroup - Server 
Administration Dialog Box will be displayed.

3 Click Next > . The Customize Workgroup - Database Options Dialog Box is displayed.

4 Click Default Permissions . The Authorization Defaults Dialog Box will be displayed.
Configure the Client Permissions: Set Default Permissions
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Figure 4-1: Setting the User Level

5 Three User Level  permissions (User, Author, and None) are available from which to select. Select 
the desired Default User Level  from the pull–down menu. The Level indicated will automati-
cally be assigned to each user as they are added to the database. Individual access privileges may 
then be modified on a per–user basis as needed.

6 Default permissions can be set for each Category and Desktop in the Shared Database. Categories 
are listed as Type C. Highlight each one individually and assign the desired Read, Write, and Delete 
permissions. Desktops are listed as Type D. Highlight each desktop and assign the desired Read 
permission.

The Authorization Defaults dialog uses a list view control to list the shared objects for which 

permissions can be modified. Similar to Windows Explorer, a click on the column header will 
sort that column and clicking again will reverse the sort order from ascending to descending.

:Shortcut The keyboard equivalent for sorting each column is ALT+1 for column 1 (view name), ALT+2 
for column2 (view type), and ALT+3 for column 3 (category).

Multiple categories or multiple desktops may be highlighted and their permissions modified at the 

same time. Sort the list by type, then hold down the SHIFT key on your keyboard to select a 
range of objects. Or hold down the CTRL key and then click each object you want.

Figure 4-2: Selecting multiple desktops

Note: Write and Delete permissions for desktops are granted to users with author level access. The 
only relevant permission that needs to be set for desktops is the Read permission. When setting 
permissions, if the selection includes one or more desktops, only the Read permission may be set. For 
full control over all applicable permissions, it may be helpful to sort by the Type  column to group similar 
objects together.

7 Repeat the above steps to set permissions for the next group of objects. Be sure to click Deselect 
All  to select a new group of objects before re-setting the permissions.

8 When the default permissions are as desired, click on Save. The Database Options dialog is again 
displayed. 

9 If the default permissions need to be overridden for specific individuals in the workgroup, click Next 
> to change the permissions for those users. Otherwise press Finish  to close the dialog.
Configure the Client Permissions: Set Default Permissions
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Any users who enroll from this point on will be given the indicated Default User Level  

with the corresponding permissions immediately upon being enrolled. Existing users who 
are already enrolled to the database are not affected by this change.

If you have finished configuring permissions proceed to the next chapter, “Configure 
Communication Settings” on page 31, to continue setting up the Commence Workgroup. 

If stricter permission control is required for the database, see the section titled "Selective 
Permissions".

Assigning Permissions
If some users should be assigned permissions other than the default settings, the 

permissions can be configured on a per–user basis.

Perform the following procedure to change a user’s permission level as well as the 
permissions for a shared category:

1 Select Customize -> Workgroup .

2 Click Next>  two (2) times to display the Customize Workgroup - Permissions Dialog Box. The 
"Set Permissions for:" section will show a list of all users that were entered into ComAdmin.

3 Select the user(s) for whom permissions are to be modified. Selecting groups of users (such as 
users in the same department) is permitted on this screen. Simply click once on each username 
to select the additional users. If more than one user will be assigned identical permissions, 
multiple users may be selected at the same time so that their permissions may be modified at 
the same time.

4 Click Edit Permissions... . The Edit Authorizations Dialog Box will be displayed. 

5 From the User Level  pull–down menu, select the permission level that is to be assigned to the 
user(s).

6 Category and Desktop Permissions can be modified for the selected user(s). Categories are 
listed as Type C, and Desktops are listed as Type D. Highlight each one individually and assign 
the desired Read, Write, and Delete permissions. For details on how to work with the Edit 
Authorizations Dialog Box, see “Set Default Permissions” on page 24.

7 When all permissions for the selected user(s) are as desired, select Save.

8 Repeat all steps for the next group of users. Be sure to deselect the previous user(s) before re-
setting the permissions.

9  Click Next >  to continue configuring the workgroup. Otherwise press Finish  to close the dialog.

Once you have finished configuring permissions proceed to the next chapter, 

“Configure Communication Settings” on page 31, to continue setting up the Commence 
Workgroup. If stricter permission control is required for the database, see the section 
titled "Selective Permissions".

Selective Permissions
Defining Selective Permissions for a shared category allows the fine–tuning of exactly 

what items a user can view and change. For example, if a user does not need to view all 

items in a shared category, the Commence Administrator may set the Read permission to 
Selective for the specific category. The user will then receive only those shared items to 
which they are connected. This allows confidential data to be shared only with those 
Configure the Client Permissions: Assigning Permissions
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users who need to view it. It also improves the synchronization performance, since there is 

less data that needs to be synchronized with all Client Databases. The Server Database 
contains all shared data, even though Clients may receive only a subset of the shared data.

Note: While Selective Permissions may give the administrator the greatest level of control over items 
in a category, it is not necessary to use this option to setup a typical workgroup.

Using selective permissions is a straightforward way of giving users access to items in a 
shared category on a per–item basis. Simply put, If a shared item is connected to a user, that 

user can view, modify, or delete the item. If the user is not connected to the item, then no 
access is granted. This permission requires that a connection exist from the shared item to 
an item in the category that contains items for all users in the Commence Workgroup (i.e., 

the (-Me-) item). 

Assign Users In order to use Selective Permissions for shared categories, the Selective Permissions 
parameters must first be configured. One setting defines the category and Commence items 
which represent the users in the Commence Workgroup. It is also necessary to select which 

connections are used with each shared category that uses Selective Permissions.

Perform the following procedure to define the category and items that represent users:

1 Launch Commence.

2 If the desired Shared Database is not the database that is open, open it by selecting the Commence 
Application button  -> Open/Manage Database . Highlight the desired database, and click Open .

3 Select Customize  -> Workgroup  from the Menu Bar.

4 Click Next> . The Customize Workgroup - Database Options Dialog Box will be displayed.

Figure 4-3: Database Options dialog box

5 Select Assign Users . The Assign Users to Commence Items Dialog Box will be displayed. 
Configure the Client Permissions: Selective Permissions
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Note: Items that are used to represent users in the Workgroup must be shared items, and will 
need to be added to the selected Person category before using this dialog. If an item does not exist 
for each of the users in the Commence workgroup, press the OK button to close this dialog. Add 
the appropriate shared items to the selected Person category, and return to this Dialog Box. 

6 Select a Person Category  from the pull–down list. The category should be one that contains an 
entry for each Commence User that has access to the shared database. This is the category 
where internal Employee names would be entered. In the Customer Relationship Management 
applications, this information is stored in the Contact category. Previous versions of the 
database used the Person/Company category to store information about the individual and their 
company.

7 The Users  listed on the left side of the screen are the user names and login ID’s that were 
entered into ComAdmin. The Person Items  listed on the right side of the screen are the names 
you entered into Commence. You will need to match up the Users from ComAdmin with the 
corresponding Person Items in Commence. Select the username on the left, then select the 
same person’s name on the right. Click Assign Person .

8 When all users have been assigned to a corresponding Commence item, select OK. 

Select 
Connections

Perform the following procedure to select the connections to be used with Selective 
Permissions:

1 From the Customize Workgroup - Database Options Dialog Box, press the Select Connections  
button. The Select Connections for Selective Permissions Dialog Box will be displayed.

Figure 4-4: Select connections dialog box

2 Select the category to configure, and then select the appropriate connections for the read, write, 
and delete permissions. For example, the Calendar category can be set so that the Calendar is 
for Person/Company connection controls the user’s read permission. Similarly, the write and 
delete permissions can be controlled by a different connection, such as the Calendar Coordi-
nated by Person/Company connection.

3 Click OK.

Selective Permissions can now be used for this shared category.
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For example, if a sales database includes a contacts category, a manager would have the 

category permission of All  for read, write, and delete. A salesperson might have read, write, 
and delete permissions for the category set to Selective . This would allow each salesperson 
to view, edit, and/or delete their own contacts, but have no access to those contacts for other 

salespersons.

Proceed to the next chapter, “Configure Communication Settings” on page 31, to continue 
setting up the Commence Workgroup.
Configure the Client Permissions: Selective Permissions
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Chapter 5: Configure 
Communication Settings
Each Commence user has the ability to synchronize information with the Commence 
Server by sending files using either a shared LAN directory, e–mail, or the Internet. In 
order to synchronize, the Server must be configured with each user’s communication infor-

mation.

For more information about the three methods of communications refer to “Running 
Commence Workgroup” on page 45.

Before configuring the communications information, make a list of all anticipated users 
and how they intend to communicate with the Commence Server. If all users will be using 

the shared LAN directory then there is no need to set e–mail or Internet parameters. If e–
mail is to be used, verify that all users have been added to the e–mail program and their 
user IDs are known. If the Internet is to be used, verify that the specified Internet FTP 

directory has been created, and that all affected clients have full access to this directory.

Note: The Commence Server can synchronize using a shared LAN directory, e–mail, and the 
Internet, but a single Client can use only one of the three methods.

Define Server Settings
Three sets of Server Communications Settings are provided (e.g. one for each of the 

available synchronizing methods.) Depending upon the method(s) used for synchronizing 
updates, one or more of these sets of parameters must be configured. The methods 
available for synchronizing data are:

• Shared LAN Directory  - used when a Local Area Network (LAN) is used by the Workgroup; a 
directory which is accessible by both the Server and Clients is used to distribute updated information

• E–Mail  - uses electronic mail to send and receive updated information for the Shared Database

• Internet FTP Directory  - uses File Transfer Protocol (FTP) commands to send and receive 
updated information for the Shared Database over the Internet.

Perform the following procedure to define Server Communications Setting:

1 Select the Customize -> Workgroup  command. Click on Next >  two times. The Customize 
Workgroup - Communications Dialog Box will be displayed.

2 In the Server Communications  section, click Configure . The Workgroup Communications 
Dialog Box will be displayed. 
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Figure 5-1: Server communication parameters 

3 At this point, each of the sets of Communications Parameters may be defined. For 
completeness, instructions are provided in the following sections for each set of Server Commu-
nications Parameters. One or more of these sections may be skipped if the information is not 
pertinent to a particular installation.

Configuring 
Shared LAN 
Directory 
Parameters

Perform the following procedure to configure the Server to use a Shared LAN Directory 

for exchanging synchronizing information:

Caution: The Shared LAN Directory is NOT the same as the Server data directory. Do not point to 
a directory that is already in use by other Commence files, such as the Server database, the 
Workgroup Administration Files, or the Program Directory. 

1 Select the Customize -> Workgroup  command. Click on Next >  two times. The Customize 
Workgroup - Communications Dialog Box will be displayed.

2 In the Server Communications  section, click Configure . The Workgroup Communications 
Dialog Box will be displayed. 

3 From the Workgroup Communications Dialog Box, highlight Shared LAN Directory  and select 
the Edit  button. 

4 Set the path for the Shared LAN Directory .   Enter this path as it would be seen by the 
Commence Server. It is through this directory that the Server will communicate with the Clients 
by sending and receiving data files. The directory selected should be accessible to all users, 
and should be a new directory that is not used by any other program or Commence. All users 
require full access (read/write/create/delete/etc.) to this directory. 
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Note: If unsure of the path to the Shared LAN Directory, click on Select . To create a new, empty 
directory (recommended), click Create Directory , provide the name of the new Shared LAN Directory, 
click OK, then click OK again. If the desired directory exists, navigate to the directory, highlight it, and 
click OK, then click OK again. 

5 Indicate how frequently (in seconds) the Server should check the shared LAN directory for data 
updates sent by Clients. A very small number will guarantee that updates are processed in a timely 
manner, although the Server may be busy for extended periods of time. This limits the Server’s 
ability to run other tasks. The default value for this is every 15 seconds. This value should be 
adjusted to meet the specific needs for the Workgroup being established, as well as the hardware 
specifications.

6 When the Shared LAN Directory parameters have been configured as desired, select OK. The 
Workgroup Communications Dialog Box will be displayed.

Configuring E–
Mail Parameters

Perform the following procedure to configure the Server to use E–Mail to exchange 

synchronization information with the clients:

1 Select the Customize -> Workgroup  command. Click on Next >  two times. The Customize 
Workgroup - Communications Dialog Box will be displayed.

2 In the Server Communications  section, click Configure . The Workgroup Communications Dialog 
Box will be displayed. 

3 From the Workgroup Communications Dialog Box, highlight E-Mail  and select the Edit  button.

Note: It is assumed that the e–mail application is already installed and operational.

4 Configure the E-Mail  parameters as follows:

• Mail Program  - select the appropriate mail program/protocol from the pull–down menu.

• Post Office Path  - [only necessary if using a VIM–based mail system, such as Lotus Notes.]

• Exchange Profile Name  [only applies to MS–Mail or MAPI compatible programs] - the name used to 
log into MS–Mail or other MAPI compatible program. 

• Login Name  [only applies to CMC–compatible programs] - the name used by the Server to log into 
the E-mail account. This is the account that the Server will be using to send/receive updates to and 
from clients.

• Password/Verify Password  - the password associated with the Exchange Profile Name/Login 
Name defined above.

Note: Although the same mail account can be used for the Server and Clients, it is strongly recom-
mended that the Server and each Client be assigned separate mail accounts.

5 When the Server’s e–mail login information is correct, select OK.

6 Next, the e–mail address for the Server must be specified. This is the address to which Clients mail 
their update information during a synchronization.

7 Indicate how often (in minutes) the Server will check the mail server for Client synchronization 
requests. This number should not be very large in order to assure the timely receipt of updated infor-
mation by the Server. A recommended value is ten (10) minutes.

8 Select OK when done. The Workgroup Communications Dialog Box will be displayed.
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Configuring 
Internet FTP 
Directory 
Parameters

Synchronizing via the Internet is much the same process as synchronizing via a shared 
LAN directory, only instead of the directory’s being located on a LAN, it is now located 

remotely and is accessed via dial–up service (e.g. Internet Service Provider) or a 
dedicated Internet connection. The transferring of synchronization files between Client(s) 
and Server is then done using File Transfer Protocol (FTP) procedures.

Perform the following procedure to configure the server with the Internet FTP Directory 

information:

1 Select the Customize -> Workgroup  command. Click on Next >  two times. The Customize 
Workgroup - Communications Dialog Box will be displayed.

2 In the Server Communications  section, click Configure . The Workgroup Communications 
Dialog Box will be displayed. 

3 From the Workgroup Communications Dialog Box, highlight Internet FTP Directory  and select 
the Edit  button. The Server Communications dialog will appear.

Figure 5-2: Setting the Server Communications for FTP synchronization

4 Enter the Internet FTP Directory  information. The format of this address is typically an IP 
Address, or sometimes ftp://DIRECTORY_NAME. If the Internet FTP Directory is unknown, it 
should be available from the Network Administrator responsible for the FTP site.

5 Enter the User Name  under which the Server will log into the Internet FTP Directory. It is recom-
mended that the Admin  login be used.

6 Enter the Password  for the Server’s Login ID.

7 Enter the Password again to Verify Password .

8 Indicate how often (in minutes) the Server will check the Internet FTP Directory for Client 
synchronization requests. A recommended value is ten (10) minutes at the server (or three 
times as fast as the client interval).

9 After the Internet FTP Directory parameters have been configured as desired, select OK. The 
Workgroup Communications Dialog Box will be displayed.

After all desired Server Communications Parameters have been successfully 

configured, select OK  from the Workgroup Communications Dialog Box. The Customize 
Workgroup - Communications Dialog Box will again be displayed.
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Define Client Settings
Once the Commence Server has been configured properly for each of the methods to be 

used for synchronizing, each Client must in turn be configured as well. Unlike the Commence 
Server, which is capable of being configured for all three means of synchronizing (i.e. Shared 

LAN directory, e–mail, and/or an Internet FTP directory), a Commence Client is capable of 
using only one method of synchronizing at any given time. The method of synchronization 
you choose may be changed at any point by resetting the Client Communications Parameters 

at the Server and at the Client. However, a Client cannot be configured for multiple methods 
of synchronizing simultaneously.

E–Mail Parameters Perform the following procedure to configure a Commence Client to use e–mail for 
synchronization:

1 From the Customize Workgroup - Communications Dialog Box, highlight a user name in the Client 
Communications  section. 

2 Click the Configure button at the bottom of the Dialog Box.

3 Select the Communicate with Server using: E–Mail  radio button.

4 Click OK. The Client Communications Dialog Box will be displayed.

5 Complete the User Address  for the Client. This is the address to which the Server will send 
synchronization information that is intended for this Client.

6 Click OK to return to the Customize Workgroup - Communications Dialog Box.

Shared LAN 
Directory 
Parameters

Perform the following procedure at the Commence Server to configure a Commence Client 

to use a Shared LAN Directory for synchronization:

1 From the Customize Workgroup - Communications Dialog Box, highlight a user name in the Client 
Communications  box. 

2 Click the Configure button at the bottom of the Dialog Box.

3 You can specify that this client will Communicate with Server using:  the Shared LAN directory. 
Note that the default method for synchronizing data within a Commence Workgroup is using 
a Shared LAN Directory. This step is only necessary if you are switching from a different 
method of synchronization back to using shared LAN directory.

4 Click OK. A message indicating that no further configuring is necessary is displayed. See the 
following figure.
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Figure 5-3: Choosing shared LAN directory

5 Click OK to return to the Customize Workgroup - Communications Dialog Box.

Internet FTP 
Directory 
Parameters

Perform the following procedure at the Commence Server to configure a Commence 
Client to use an Internet FTP Directory for synchronization:

1 From the Customize Workgroup - Communications Dialog Box, highlight a user name in the 
Client Communications  box. 

2 Click the Configure button at the bottom of the Dialog Box.

3 Select the Communicate with Server using: Internet FTP directory  radio button.

4 Click OK. A message indicating that no further configuring of parameters is necessary is 
displayed.

5 Click OK to return to the Customize Workgroup - Communications Dialog Box.

Repeat the above procedure for each remaining Client that is to have its Communica-
tions Parameters configured.

Users’ communications parameters may need to be updated if the methods available 
for syncing change. For example, if a user usually works in the office, they would 

typically be connected via a shared LAN directory. If they begin using Commence on a 
laptop from outside of the office, e–mail communication would allow the Client Database 
to communicate with the Server even when away from the office. The server will then 

need to be reconfigured so that it sends (and receives) synchronization data from the 
Client via e–mail. Additionally, the user will need to configure the Client Database to 
communicate via e–mail.

After all Client Communications Parameters have been properly configured, proceed to 

the next chapter “Register Clients” on page 37 to continue configuring the Shared 
Database.
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Chapter 6: Register Clients
Each client must be registered with the Shared Database. Registering will create a link 
between the Clients and the Server. Registering from the Server will generate an 
Instruction Sheet,  which is to be given to the appropriate user. This sheet includes infor-

mation necessary in order to enroll as a user from the Client Database. Also, initialization 
information will be sent to each client using the communication settings as configured 
above.

Personalizing the Instruction Sheet
When you register a client, Commence will ask if an Instruction Sheet should be generated for 

this user. The instruction sheet  provides step–by–step instructions for enrolling a client to 

the shared database. Since the instruction sheet is a text file generated by Commence, it 
can be printed out, e–mailed, or faxed to the user.

The instruction sheet is generated from a template file that should be customized to 
include information specific to your installation. At a minimum, it should include the 

Commence Administrator ’s name and telephone number so that users can contact the 
Administrator if they experience any difficulties during the enrollment. The template file is 
a text file that can be edited using any text editor (such as Notepad or WordPad).

There are three template files included with Commence. They are stored in the \wgfiles6 

folder beneath the commence program directory.

• steps1.txt  - is the e–mail template file

• steps2.txt  - is the shared LAN template file

• steps8.txt  - is the Internet FTP template file

Each template file has special markers that Commence replaces with the appropriate 
data to create the instruction sheet. Some examples of the special markers include (-
Directory-)  and (-Serial Number-) . Do not remove these markers or the instruction sheets 

will be missing vital information!

Synchronizing Personal Information to each Client
Normally the personal information is set at the client workstation by the end user after 

the enroll has taken place. However in some cases, especially if selective permissions are 
enforced in the shared database, it is crucial that the personal information be set as soon 
as possible. Rather than leave this important task up to the end user, the Commence 

Administrator can opt to automatically synchronize these settings to a newly enrolled client 
during the initial synchronization.

To use this feature:
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1 Verify that the Commence Server is running, and the desired Shared Database is active.

2 Select Edit -> Preferences -> Personal Info . Choose the Category:  where the Commence 
client names have been entered. This is typically the Person/Company category. Set Your 
Name:  to the item that will represent the Commence Server. This user will be mapped to the 
admin login ID. If an item does not exist for the Commence server, use the Add New Item  
button to add one.

3 Select Done  to close the Personal Info dialog.

4 For the Category selected above, add an item for each client that will be enrolled.

Note: Items that are used to represent users in the Workgroup must be shared items, and will 
need to be added to the selected category before continuing.

5 Select Customize -> Workgroup from the Menu Bar. The Customize Workgroup - Server 
Administration Dialog Box will be displayed.

6 Click Next > . The Customize Workgroup - Database Options Dialog Box is displayed. 

7 Click Assign Users . The Assign Users to Commence Items Dialog Box will be displayed. 

8 Select a Person Category  from the pull–down list. Choose the same category as in step 2 
above.

9 The Users  listed on the left side of the screen are the user names and login ID’s that were 
entered into ComAdmin. The Person Items  listed on the right side of the screen are the names 
you entered into Commence. You will need to match up the Users from ComAdmin with the 
corresponding Person Items in Commence. Select the username on the left, then select the 
same person’s name on the right. Click Assign Person .

10 When all users have been assigned to a corresponding Commence item, select OK. 

Proceed with the next section titled "Register Clients With the Shared Database". After 
the clients have enrolled and received their copy of the shared database, the (-Me-) item 

will be pre-set in each client database to the appropriate user item mapped at the server.

Note: The (-Me-) item setting only synchronizes with the client when the client database is first 
created. If changes are made to this setting at the server after the clients have been registered, 
those changes will not synchronize to the clients. The client settings may be updated from each 
individual client workstation by selecting the Edit -> Preferences -> Personal Info  command.

Register Clients With the Shared Database
Perform the following procedure at the Commence Server to register a client with the 

shared database:

1 Select the Customize -> Workgroup  command. Click Next > four times. The Customize 
Workgroup - Register Dialog Box will be displayed.

2 From the list of All Users highlight a user that is to be registered with the Shared Database.

3 Click Register .   The Register User Dialog Box will be displayed.

4 Click OK. An informational Dialog Box will be displayed, providing the authorization key for the 
user just registered. You may write this information down to take with you to the client PC if you 
plan to enroll the client yourself or you may create an instruction sheet to give to the user by 
proceeding with the remaining steps. 

5 Commence will ask if an Instruction Sheet should be generated for this user. If you have already 
Register Clients: Register Clients With the Shared Database
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taken note of the pertinent information in the previous step, you may click No. Otherwise, click Yes 
to save the Client Enrollment instructions to a file. Select a directory in which the instruction sheet 
will be stored, and what the name of the user–specific sheet will be.

6 Click Save. An informational dialog box will be displayed indicating that the instruction sheet has 
been successfully saved.

7 Click OK.

8 Repeat the steps above for each user to be Registered with the Shared Database.

View Registration Details
Registration Details for each registered user may be viewed. This shows the Authorization 

Key if needed and allows the instruction sheet to be recreated. Additionally, each registered 
user may be re–registered or may be re–synchronized with the Server. Note: Only re-register 

or re-sync a user if a problem has occurred.

Perform the following procedure to view the registration details:

1 From the Customize Workgroup - Register Dialog Box, highlight a registered user from the list of 
Registered Users.

2 Click Details . The Registered Users Dialog Box will be displayed.

The Full Name , Login ID , and Authorization Key  for the selected registered user will be 

listed.

From here, one or all of the following may be done:

• Create Instructions - Creates an instruction sheet for the registered user. This is useful if you lost 
the original instruction sheet, or have changed the method of synchronization for this user.

• Re–Register  - Sends the initial synchronization packet to the registered user, enabling the user to re-
attempt the enrollment. Use this command ONLY if the user is having difficulty enrolling to the shared 
database or if the original synchronization packet has been lost or mis-directed.

• Re–Sync - Sends the complete database to the registered user. All shared information contained in 
the shared database will be sent. Use this command only if the client database has fallen out of sync 
with the server database. USE WITH EXTREME CAUTION.

After all users have been registered with the Shared Database, proceed to the next chapter 
titled "Enroll in the Shared Database" to continue the Workgroup Installation.
Register Clients: View Registration Details
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Chapter 7: Enroll in the Shared 
Database
Install Commence RM on Clients
After the Server has been configured, Commence RM must be installed for each user. 

Clients can install the software themselves. However, the Commence Administrator may 

be called upon for assistance.

Refer to Chapter 2 of the Getting Started Guide for detailed steps on how to setup 
Commence RM on a client PC.

Caution: If running a Client on the same PC as the Server, DO NOT install Client Software. Instead, 
refer to “Running a Server and Client on the same machine” on page 66 for further instructions.

Enroll Clients
After installing Commence RM, each user must enroll in the shared database. The 

enrollment process provides each client with a copy of the shared database directly from 
the Commence Server.

It is not required that the Commence Administrator enroll each user personally. A user 

can enroll with the Shared Database on their own by following the steps in the instruction 
sheet. However, the Commence Administrator may be called upon for assistance.

Perform the following procedure to enroll a client to the shared database:

1 Verify that the Commence Administrator has registered the user to be enrolled with the server.

2 Launch Commence at the Client PC.

3 Open a standalone database. This is a database that is neither a Client Database nor a Server 
Database.   If necessary, create a new database by selecting the Commence Application 
button   -> Open/Manage Database  command.

4 Select Customize  -> Workgroup . The Customize Workgroup – Enroll Client Dialog Box will be 
displayed.

5 Select the Next >  button.

6 Enter the authorization key  in the space provided. This number is found on the Instruction Sheet 
generated when the Client was registered with the Server. This is a unique number for each user 
and is available from the Commence Administrator.

7 Select the Next >  button. When each user was registered with the Commence Server , it was 
established how the Client Database would synchronize with the server (i.e. via a shared LAN 
directory, by e–mail, or the Internet.) The specific communications parameters must now be 
defined in order to enable the synchronizing of data between the Server and Client Databases. 
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8 Select Configure . The Workgroup Communications Dialog Box will be displayed.

9 Indicate by which method data synchronization will take place for the Client that is being 
enrolled.

10 Click OK and proceed as indicated below. Any specific information required may be found by 
referring to the information sheet provided by the Commence Administrator.

11 When all Workgroup Communications parameters have been configured, the Customize 
Workgroup – Enroll Client Dialog Box is again displayed. Select the Next >  button.

12 Next, information about the Local Database needs to be completed. See the following figure.

Table 7-1: Conf igurat ion opt ions

Method of  
synchronizat ion

What to enter. . .

Shared LAN 
Directory

 Indicate the path to the Shared LAN Directory , as 
well as the frequency with which Commence is to 
check this shared LAN directory for synchronization 
requests. When the information is complete, select 
OK. Proceed to step 11.

E-mai l

• Select the Mail Program  that will be used, as 
well as all related information that is indicated 
based on the mail program selected.

• When all information is complete, select OK. 
Indicate the Server E–Mail Address , as well as 
the frequency with which Commence is to check 
the e–mail program for synchronization requests.

• When the information is complete, select OK. 
Proceed to step 11.

Internet FTP 
Directory

Enter the FTP login information. When the 
information is complete, select OK. Proceed to step 
11.
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Figure 7-2: Specify client database name and path

• Local Database Name  - The Local Database Name is a descriptive name that will appear in the Title 
Bar across the top of the Commence window. This name does not have to match the server database 
name.

• Local Database Path  - This is the directory in which the client copy of the shared database is stored. 
For example, c:\ProgramData\Commence\Commence\8.0\mydata. Choose a new directory on the 
client’s local hard drive. Do not choose the path to an existing database, or a directory that contains any 
files used by Commence or any other program. If the directory you specified does not exist, Commence 
will automatically create it.

13 Select the Next >  button. When all information has been correctly entered, a message indicating this 
is displayed.

14 Select Finish . Commence will open the new client database and proceed to process the initial sync 
from the Commence Server. This will download all information from the Commence Server to the 
Client Database. This may take several minutes. While Commence is busy, the Sync in Progress 
Message Box will be displayed.

When all of the data has synchronized from the Commence Server to the Client Database, 

the Message Box will be dismissed.

Caution: The procedure just described must be completed by each client in order to enroll and obtain 
a personal copy of the shared database. It is not possible to simply copy the shared database for use 
by a Client.

This completes the Installation and Configuration of a Commence Workgroup.

For more detailed information about Administering a Commence Workgroup, refer to 
“Maintaining a Commence Workgroup” on page 53.
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Chapter 8: Running Commence 
Workgroup

Using a Commence Client is almost identical to using Commence. The ability to add, edit, 

delete items, categories, etc., is still there. The only difference is that the data and defini-
tions are specified as local or shared. Therefore, Commence Workgroup extends the features 
and functions of Commence over a network of local and remote users for a shared workgroup 

environment.

There are two classifications of data that are maintained within a Client Database:

• Local , or private, information is data that is maintained and available only from within the Client 
database. It does not synchronize to the Server Database or to any other Client databases. The only 
way to read, modify, add, or delete private data is from the PC on which the Client Database resides.

• Shared data is synchronized to the Server Database and all other Client Databases in the 
Workgroup. Consequently, all users can read, write, and delete it, depending on their permissions. 

Most data and definitions used by Commence are able to be shared. However, there are a 

few exceptions as listed below.

The following objects are able to be shared between users:

Agents, Categories, Color Templates, Connections, Desktops, 

Detail Forms, Import/Export Templates, Items, Letter Templates

• Views

The following items are not able to be shared between users:

• Preferences

Shared objects are indicated by one of three methods:

• An asterisk (*) appears next to the name.

• A Shared  checkbox is checked.

• Within a detail form, the Shared  toggle button  is depressed.

Displaying Shared or Local Items
A View may be created that is filtered to display only shared or only local items.

Perform the following procedure to create a View that will display only Shared or only Local 
items:

1 Open a view of the desired Category.

2 Select Customize  -> Filter View  from the Menu Bar.

3 Click an unused filter tab.

4 Highlight Filter for all items: (Shared vs. Local) .

5 Select the Shared  or Local  radio button, depending upon which items are to be viewed. If Shared  is 
selected, only those items identified as Shared will be displayed. If Local  is selected, only those 
items identified as Local will be displayed.

6 Select Save.
Running Commence Workgroup: Displaying Shared or Local Items
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Modifying Data Definitions
Although the Commence Server can be used to modify data definitions (views, 

categories, connections, etc.) it is not recommended to use the Server to modify large 
amounts of data on a regular basis. Rather, perform all data modifications from a Client 

Database that has been assigned the appropriate permissions. If necessary, run a 
Commence Server and Client on the same machine. Refer to “Running a Server and 
Client on the same machine” on page 66 for further information.

Maintaining Private Information For Shared Items
If a category is shared, then all of its fields are also shared. A shared category cannot 

include local fields. If local information is to be maintained about a shared item, this may 

be accomplished by using a Connection. For example, if the Person category is desig-
nated as shared, notes pertaining to each Person can be maintained by creating a local 
Personal Notes category and adding a connection between the two categories.

Synchronizing via LAN, E–Mail, and the Internet
The Commence Server and Clients communicate by sending data files to each other. 

This communication can be accomplished by using a shared LAN directory, an external 

e–mail program, or the Internet. Although each client can use only one of these mecha-
nisms for communicating, the server is able to use all three since it must communicate 
with all clients.

Using a Shared LAN Directory requires that the Server and each Client have access to 

a common LAN directory. Each client can use a different drive mapping or directory path, 
but each must point to the same physical directory.

Note: Even when not connected to the network, the Client Database may still be accessed and 
updated. Any changes made will synchronize when the Client reconnects to the network.

For users without a LAN connection, Commence is able to exchange files by using an 
external e–mail program. Commence works with any 32-bit e-mail program (such as 

Lotus Notes or Microsoft Outlook) that supports either VIM or MAPI protocols.

If the Internet is to be used to exchange files, an Internet FTP directory must be 
created to which all affected users have full access.

Special Considerations
Although using Commence Workgroup is very similar to using Commence, there are 

several considerations which must be remembered. The following sections discuss these 
Special Considerations.

Agents Agents are very powerful tools. They have the ability to change all data within a 

database with a simple click of a button. When creating agents in a Commence 
Workgroup, there are some important things that must be considered, such as:

• Should the Agent be designated Local  (i.e. available only for use by the Client database), or 
should it be designated Shared ?
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• When using a Save Item  Agent, should the Agent be triggered when the item is saved at the local 
database or when it synchronizes into the database?

There are some instances when an Agent should be shared and located on each Client 
copy of the Shared Database. For example, an Agent used to process appointment alarms 

would be Shared because all users would want to be notified when it is time for an 
appointment.

Any Agent that is unique to a single user should be local so it runs on only one PC.

Save Item  triggers in workgroup databases have several additional options that enable 
expanded control over their operation.

The Trigger If... an item is added/edited now includes options for as local  or as shared . 

This instructs Commence that the agent should run whenever an item is saved as a either a 
shared or a local (private item) at the Client Database.

Selecting the Options  button provides a means of fine–tuning exactly under what condi-
tions the Save Item trigger fires. 

An item can be added or modified in a number of ways, such as manually entering the 

information into a Detail Form, automatically adding it via an Agent, Importing the information 
from a different database application, DDE from another application, or Sync Linking with a 
remote or base database. By default, the Save Item  trigger fires when an item has been 

manually added/edited via a Detail Form. However, the option of triggering when data has 
been entered/modified by a specific method is selectable. Select the desired method(s) of 
adding and/or editing items for which the agent is to fire. Each of the methods listed can be 

independently selected or deselected.

The Workgroup  option will cause the agent to run when the specified item is saved at 
another Client Database and is added as a result of a synchronization request. An example 
of this situation are:

• A new appointment is synchronized to a Client Database. The user/owner of the Client Database is 
included as one of the participants. An agent can display a message box informing the user of this new 
appointment that has been scheduled for them.

Data File Fields A Data File Field is a Commence field that references an external file on a local or network 
drive. A common example of data files fields are the logged letter items in the database that 
reference word processor documents. When a Shared item containing a Data File Field is 

synchronized with a Client Database, a series of events takes place:

• The referenced data file is copied from the source directory to each into each Client’s External Data 
Files  directory. This directory is defined via the Edit  -> Preferences  -> Other  selection from the Client 
Database Menu Bar, and is not necessarily the same for each Client.

• The Commence Data File Field is updated to reflect the path to the file’s location on the Client 
Workstation. That is, the path is corrected to use the path specified by the Client for the External Data 
File  directory.

Note: The data file is only synchronized when the item is first added and when the filename is edited. It 
does not synchronize when the contents of the referenced file are changed.

Instead of copying these files to all Clients, it is possible to provide all users with access to 

data files without synchronizing them. The Synchronize Data Files  option must first be 
disabled in order for Commence to preserve the original Data File Path.

Perform the following procedure to disable automatic synchronization of data files and 
begin using a central data file directory:
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1 Selecting Edit  -> Preferences  ->Database  from the Menu Bar

2 Turn off the Synchronize Data Files  option on the Server and all Clients.

3 Use Network Neighborhood to map the same drive letter to a Shared Directory on the 
network to which all users have access. 

4 Copy any existing data files to this Shared Directory.

Commence will preserve the original path to the file found in the Data File Field, thus 
pointing to the correct file.

Peer–to–Peer 
Networks

Peer–to–Peer networks require additional support when sharing files in a common 

shared directory. This is because the file may have the path of C:\DOCS\ABC.TXT  at the 
Commence Server PC, but the Client PC references the file using the path D:\ABC.TXT . 
The Commence Server can modify or translate the path so the client will be able to 

reference the file using the proper path.

Perform the following procedure to configure the Commence Server to translate Data 
File Field paths in Peer–to–Peer networks:

Caution: Perform the following only if using a Peer–to–Peer network.

1 Select the Commence Application button   -> Open/Manage Database .

2 Highlight the Server Database, and select Edit . Determine the path of the Commence Server 
database.

3 Close the Commence Server.

4 Navigate to the directory in which the Commence Server is stored.

5 Locate the DATA.INI  file in this directory.

6 Using any text editor (e.g. Notepad) edit the DATA.INI  file by adding to the [Workgroup]  
section the following command:

XLAT={server path},{client path}

where:

server path  = the Server Path that is to be translated for use by the client (i.e. 
c:\docs\ )

client path  = the Client Path with which the “Server Path” will be replaced (i.e. d:\ ).

The brackets, {}, around the each path and trailing backslashes must be included. 

Using the sample paths listed, the command would then be:

XLAT={c:\docs\},{d:\}

For example documents are stored in C:\PUB\DOC1\ on the Server. The C:\PUB\ 
directory is the Shared Directory. Clients access the C:\PUB\  directory using D:\ . The 
translation would then have the Server Path equal C:\PUB\  and the Client Path equal D:\ . 
The result would be that files found in C:\PUB\DOC1\  on the Commence Server to 
appear in D:\DOC1\  at the Commence Clients.

Note: The Client Path must be identical for all Clients. In the above example, all Clients must 
access the C:\PUB\DOC1\  directory using the D:\ drive.
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Image Fields Image Fields are Commence fields that store and display bitmap and other types of images 
(pictures). The information stored in an Image Field is automatically synchronized with each 

Client Database. Depending on the number of images, as well as the size of each, including 
Image Fields in a Shared Database may cause each Client Database to consume a large 
amount of disk space.

Letter Templates Letter Templates can be shared between Client Databases, and changes made to the 

Letter Templates will be automatically synchronized by Commence. Note that the Letter 
Template must be opened or modified using Commence’s Letter Template dialog boxes, not 
simply by opening the file directly from a word processor. If changes to the Letter Template 

are made directly from a word processor, Commence will not be aware of the changes, and 
therefore will not be able to synchronize these changes to other client databases.

Maintaining a 
Commence Server 
Database

The Commence Server tracks synchronization information for all Client Databases using a 
special file, SYNCLOG.PIM , located in the Server’s Database. This file will grow in size in 

order to track all changes that need to be synchronized with Client Databases. The 
Commence Server will automatically discard data that has been synchronized with all Client 
Databases and will shrink the size of this file.

Commence will only discard data that has already been synchronized with all Clients of a 

Workgroup. If a Client is inactive for a long period of time, or if the Client Database has been 
deleted but not removed from the Workgroup, the Commence Server will continue to track 
information for this Client. This will prevent the automatic maintenance of the SYNCLOG.PIM  

file from working properly, and result in an excessively large file.

All Client Databases must be opened regularly to allow Commence to synchronize with 
them. This allows Commence to reduce the amount of synchronization information that must 
be tracked within SYNCLOG.PIM .

Additionally, whenever a Client Database is to be removed, it must be done using the 

Customize  -> Workgroup  command. Going to the Register  dialog, and using the Remove  
command will remove the Client from the Server’s synchronization information so that the 
Server will no longer track information for this Client.

If the Commence database is using a large amount of disk space, check the size of the 

SYNCLOG.PIM  file. If this file represents most of the disk space used by the database, verify 
that all Clients are actively syncing and that any deleted Clients have been removed from the 
Workgroup.

For further information about maintaining a Workgroup, refer to “Maintaining a Shared 

Database” on page 55.

Workgroup Options
There are some options that are applicable specifically to Commence Workgroup. The 

following sections discuss these options.

File  -> Workgroup 
Sync Menu 
Command

This menu command instructs the Client Database to immediately synchronize any 
changes with the Server Database, and updates the Client Database with any changes from 
the Server Database. This command overrides the automatic synchronization that occurs 

periodically in situations where changes to the Shared Database must be retrieved quickly.
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This command is useful when a database contains changes that are to be shared 

immediately with another user, or if the Server contains changes that are needed quickly. 
For example, a Client Database resides on a notebook computer. Just before leaving the 
office, the Home  -> Workgroup Sync  command is used to retrieve the latest changes to 

the Shared Database before disconnecting from the network. 

Home  -> Workgroup Sync  is also useful when a Client Database is connected to the 
network via modem using remote access software. This command allows updates to be 
retrieved on demand, rather than having to wait for a scheduled synchronization. This 

reduces the amount of time that the remote connection must be kept active.

Workgroup 
Preferences

There are two Preferences that are Workgroup specific. The following sections 
describe each preference.

Set Shared 
Checkbox by 
Default

This option is used to define whether data added to a Shared Database is automatically 
identified as shared. If shared data is typically added, then this checkbox should be 
selected. If private (local) data is typically added, then clear the checkbox. Since this 

option automatically sets the Shared  button, data will automatically be shared or kept 
private unless the Shared  button’s status is manually changed on detail forms or 
definition screens.

This option also applies to the Shared  toolbar button on detail forms, as well as to the 

Shared  checkbox in the Add and Edit dialog boxes for those definitions that are able to 
be shared in a database. This option is used to set the initial state of the Shared  button, 
and can be overridden by setting (or clearing) the Shared  button, and then saving the 

data.

Synchronize Data 
Files

This option defines whether data files that are referenced by shared items are automat-
ically copied along with the shared items. If this option is cleared, data files will not be 
copied from the Client Database to the Server Database. If this option is selected, which 

is the default, all data files will be copied from the Client Database to the Server 
Database, and will be received by other Client Databases.

This option should be cleared if the data files that are referenced by shared items are 
already located in a shared directory on the network. The file name and path referenced 

by the shared item are modified to reflect the path selected for the External Data Files  
directory. This directory will need to be changed to reflect the path of the shared 
directory by selecting Edit  -> Preferences  -> Other .

This option should be selected if data files are not stored on a shared network 

directory. Selecting this option will cause Commence to copy the data files associated 
with shared items so that they are available on every Client Database. Commence will 
also automatically update the data file path to reflect the file’s location on the Client 

Workstation (the External Data File  directory), and will attempt to preserve the filename 
if possible.

Note: This option must be selected at the Server Database to enable Clients to synchronize data 
files. Disabling this option at the Server will disable it for the Shared Database, even if the option is 
selected at the Client Databases. 
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Using Sync Link in a Workgroup
Sync Link is used to keep databases on multiple PCs up–to–date with the same infor-

mation, similar to synchronization within a Commence Workgroup. Sync Link can keep a 
Commence Client Database on an office PC “in sync” with the Commence Client Database 

on a laptop or home PC. This way, a user only has to be registered once with the Server.

When Sync Link is used in a Commence Workgroup, the remote database will contain the 
same data as the base or Client Database on the network. If shared information is added or 
changed, when these changes are Sync Linked back to the Client, they will synchronize with 

the rest of the Workgroup. The user will also have to login to the remote database if that is 
required at the Client Database.

For further information on configuring and using a Sync Link Group, refer to the Commence 
User’s Guide.

Caution: Sync Link should not be used with the Server Database. The Server Database should be 
used only for synchronizing Client updates received either by shared LAN directory, e–mail, or the 
Internet.
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Appendix A: Maintaining a 
Commence Workgroup
A Commence Workgroup requires periodic maintenance to detect and prevent problems 
with the Shared Database(s). It is strongly recommended that backup copies be made 
weekly (or daily if feasible) of the Server Database. If a database becomes too large, 

archiving older data that is no longer needed will improve performance and reduce the size 
of the server backup files.

Backups of the admistrative files in the \wgfiles8  directory can be made monthly or as 
needed. The administrative files are updated whenever changes are made via the 

Customize -> Workgroup menu on the Commence Server.  For example, changes to users’ 
permissions may be required if they need access to different information in a shared 
database, or if new shared categories are added to a shared database. The wgfiles are 

also updated when users are added and updated in ComAdmin.

 The Commence Administrator will require access to the Commence Administration 
program (ComAdmin ), the Commence Server Database, as well as Network, FTP, and/or 
e–mail software in order to perform maintenance on the Workgroup and Shared 

Databases.

• ComAdmin  is used to maintain users and shared databases.

• The Commence Server is used primarily to register new users with the shared database (including 
appropriate permissions), to remove users who no longer require access to the shared database, 
and to modify permissions for existing users.

• A dedicated folder on the shared drive is used to exchange updates between the server and the 
clients. The shared drive can be either a shared LAN directory and/or an Internet FTP folder. If no 
other method of communication is available, users can exchange data with the server via e-mail, 
however your email server may impose file size limits.

The following sections provide an overview of the tasks required of a Commence Admin-
istrator while maintaining a Workgroup.

Administering Users
The Commence Server is used to maintain users’ access to the shared database, such 

as when registering new clients or modifying users’ permissions. In order to maintain 
users, the Commence Server must be running, and the Shared Database must be open.

As users are added to the Workgroup, they will need to be registered with the Shared 

Database. A data sheet containing information needed to enroll a new Client Database 
with the Server will be generated for each new user. If the user will be enrolling 
themselves, be sure to provide them with this data sheet.

Depending upon the specific access requirements for each user, it may be necessary to 

update the access privileges for one or more users.
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When maintaining a group of Users, there are several situations which may present 

themselves on a regular basis. Recommended actions are described in the following 
paragraphs.

An Existing Client 
Needs to Re-enroll

Re-enrolling a client is typically only necessary if the client database has become 
damaged due to hard disk problems, and if no recent backup of the client database 

exists. Re-enrolling creates a new copy of the client database. To re-enroll a client:

1 Open the shared database at the Commence Server. Select Customize -> Workgroup . Click 
Next>  until you reach the Register screen.

2 Select the User from the list of registered users (at the bottom half of the screen). Click 
Remove . This disconnects the previous copy of the database from the server so that 
no further updates will be accepted by the server.

Caution: Once a client has been removed from the workgroup, be sure to delete the existing client 
database at the client PC to prevent any further updates from being sent to the server. Synchroni-
zation attempts from a client that has been removed will be rejected by the Server.

3 Register  the user to obtain a new Authorization Key. Create an instruction sheet as needed.

4 At the client PC, select the Commence Application button   -> Open/Manage Database  to 
open a standalone database (one which does not say Server or Client on the Title Bar.) Proceed 
with the steps to enroll a new client as per the instruction sheet.

A New User Takes 
Over an Existing 
Client Database

If a new user will be assuming ownership of an existing Client Database, do not remove 
the previous user from the list of Registered Users or from ComAdmin . Rather, change 
the previous user’s name to the new user’s name (using Users  -> Edit  from ComAdmin ).

Preventing a 
Particular User 
from Accessing 
Data in a Shared 
Category

It may become necessary to prevent a particular user from gaining access to data in a 

shared category. Using the Commence Server, go to the Permissions screen (via 
Customize -> Workgroup ) to change the Category permissions for the given user to None 
(as opposed to All or Selective). This will prevent the user from receiving any new data in 

that shared category. It will not, however, remove the shared data that has already 
synchronized to this client. If it is necessary to completely remove all shared data from 
the category at this client, then re-enroll the client to the Shared Database.

A User with 
Selective 
Permission now 
needs Full Access 
to a Shared 
Category

1 Open the shared database at the Commence Server. Select Customize -> Workgroup . Click 
Next>  until you reach the Permissions screen. Change the Category permissions for the given 
user to All (as opposed to None or Selective).

2 Click Next>  until you reach the Register screen.

3 Select the User from the list of registered users (at the bottom half of the screen). Click Details .

4 Click Resync .

The next synchronization request received by the server from this client will return a 

complete copy of the database to the client. The complete sync will update the user’s 
database to include any missing items based on the new permissions.
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A User No Longer 
Requires Access 
to a Shared 
Database

Perform the following procedure if a user no longer requires access to a shared database:

1 Determine the user’s Workgroup ID Number. This is done from the Client Database using the Help  -
> System Information  -> Workgroup Information  command from the Menu Bar. A number such 
as 0x00006501 will be displayed. The Workgroup ID Number is determined by taking the non–zero 
portion of this number (e.g. 6501), and dropping the 01 from the end. In this case, the Workgroup ID 
Number would be 65.

2 Search both the Shared LAN Directory as well as the \workgrp  directory (under the Server’s data  
directory) for any sync files from the specific database. These files will be named, for example, 
*65.up  or *65.dwn  and should be deleted.

3 Open the shared database at the Commence Server. Select Customize -> Workgroup . 

4 Click Next>  until you reach the Register screen.

5 Select the User from the list of registered users (at the bottom half of the screen). Click Remove .

Caution: It is important that a Client Database be removed as described above BEFORE deleting the 
associated user from ComAdmin.

6 Permanently delete the user from the Workgroup using ComAdmin .

Maintaining a Shared Database
The Commence Server tracks synchronization information for all Client Databases in a 

special file, SYNCLOG.PIM , located in the directory that contains the Server Database. This 
file will grow and shrink in size as it tracks all changes to be synchronized with the Client 
Databases. The Commence Server automatically discards all data that has already been 

synchronized with the Client Databases and will reduce the size of this file.

Commence will only discard data that has already synchronized with all Clients in a 
Workgroup. If a Client is inactive for a long period of time, or if the Client Database has been 
deleted from ComAdmin but not removed from the Workgroup, the Commence Server will 

continue to track information for this Client. This will prevent the automatic maintenance of 
the SYNCLOG.PIM  file from working properly, and result in an excessively large file.

All Client Databases must be opened regularly to allow Commence to synchronize with 
them. This allows Commence to reduce the amount of synchronization information that must 

be tracked within SYNCLOG.PIM .

Additionally, whenever a Client Database is to be removed, it must be done via the 
Customize  -> Workgroup  command. Navigating to the Register  dialog, and using the 
Remove  command will remove the Client from the Server’s synchronization information so 

that the Server will no longer track information for this Client.

Caution: It is important that a Client Database be removed as described above BEFORE deleting the 
associated user from ComAdmin.

If the Commence database is using a large amount of disk space, check the size of the 
SYNCLOG.PIM  file. If this file is larger than 4 MB, verify that all Clients are actively syncing 
and that any deleted Clients have been removed from the Workgroup.

The Server copy of the Shared Database is the master copy of the database, and it is 

strongly recommended that it be backed up daily. Local agents can be added to the Server 
Database that will automatically backup the Commence Server every day. Such an agent 
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would have a Timer trigger and a Backup action, and should be designated as local so it 

only operates on the Server. Refer to the chapter on Customizing Databases  in the 
Commence User’s Guide for additional information on creating and using Agents.

Archiving If the shared database is getting too large, you should plan to archive outdated infor-
mation from the shared database. Archiving (exporting and then deleting) this data 

removes it from the Server, as well as from all Client Databases. This should improve 
performance. Typically, old appointment items, old phone log or letter log items, or any 
date or time sensitive information that is no longer required can (should) be archived. 

The information to be archived can be copied out of the Commence database by using 
the Transfer Out  command, or by using the Export  command. If access to the infor-
mation is again required in the future, use the Transfer In  or Import  commands to 

restore the data into the shared database.

Maintaining Client Databases
By following the basic routines in this section, end-users can feel comfortable that their 

database and the information they have entered is properly shared with the other users in 
their workgroup.

Synchronizing 
Regularly

All Client Databases must be opened regularly and synchronized to exchange infor-
mation with the Server Database. This allows the Commence Server to reduce the 

amount of synchronization information that must be tracked.

Manual synchronization is done by clicking the Workgroup Sync  command found on 
the Home  menu. If a reliable full-time network or internet connection is available the 
Commence Client can be setup to automatically synchronize at regular intervals. This is 

done via the Customize  -> Workgroup  command. Click OK and set the auto-sync 
interval to some number other than zero (0).

Backups Additionally, Client Databases should be backed up periodically in order to secure any 
local data that a user creates. Local (or private) data is stored only in the client database, 

and cannot be backed up with the server database. 

Disk Space Verify that the Client Workstations all have sufficient disk space. Commence requires 
sufficient disk space in the TEMP directory. This directory is used when synchronizing 
information between the Server and Client, and the amount of space needed depends on 

the amount of changed information that the Server needs to send to each Client. If a 
Client has not connected to the Server in a long time, or if a significant number of 
changes have been made to the Shared Database, there may not be enough disk space 

to store Commence’s temporary files. Disk space will need to be freed up, or change the 
TEMP directory to a drive that has more disk space available.
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Obtaining Additional Information
In order to obtain additional information about Commence Workgroup, check the 

Commence Web site, located at http://www.commence.com  on the World Wide Web. The 
Web site provides current information about maintaining and using the Commence software, 

including information on how to resolve problems.
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Appendix B: Using ComAdmin
Commence Workgroup includes a specialized program that is used for the administration 
of Users, and Shared Databases. This program, ComAdmin , is a stand–alone program 
which may be run independently of the Server Software.

Launch ComAdmin
Perform the following procedure to launch ComAdmin :

Note: The following procedure assumes that default settings were used during the installation of 
Commence. If not, slight modifications will need to be made to accommodate specific path names, 
menu structures, etc.

1 Exit from the Commence Server database.

2 From the Windows desktop, select Start  -> All Programs  -> Commence RM 5.0 Workgroup  -> 
ComAdmin . The Login Dialog Box will be displayed. 

3 Login as follows:

• Login ID  - enter admin .

• Password  - leave blank; do not type anything into this space. The admin  Login ID is typically 
reserved for use by the Administrator of the Workgroup. By design, this ID does not initially have a 
password associated with it. For Workgroup Security purposes, it is strongly recommended that a 
password immediately be assigned. Refer to Assigning an Administrator Password , found in the 
Users section later in this Appendix, for complete instructions.

4 Click OK. The ComAdmin Main Menu screen will be displayed. See the following figure.
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Figure 8-1: ComAdmin Main Menu

It is from this Main Menu that all ComAdmin  activities are initiated. To access the 

Dialog Boxes that are used for administration of the Server, click on the corresponding 
button shown on the ComAdmin Main Menu.

The following sections describe each of the administration activities that is performed 
from ComAdmin .

Users 
Commence Users are those clients who are provided access to a Commence 

Workgroup. Each user is assigned a unique login ID and password.

One special user, the Administrator, uses the login ID admin . This user has the ability 

to add, edit, and delete users and shared databases. By default, the password is blank. 
However, for protection, a password should be assigned to this login ID.

Caution: Keep the password for the admin  login in a safe place. If this password is forgotten, 
there is no way to recover it.

Perform the following procedure to access the Users area of ComAdmin :

1 Select the Users  button  from the ComAdmin menu. The Users Dialog Box is displayed.

This dialog box will initially display the Administrator (admin) as the only user. The 

Administrator is automatically added by ComAdmin when it detects a new installation.

From this screen, an Administrator can assign a Password to the admin  login ID, as 
well as add, edit, and delete users. The following sections describe each of these activ-
ities.
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Assigning an 
Administrator 
Password

As the Commence Administrator, it is critical to maintain the security of the Workgroup. By 
assigning a password to the admin  Login ID, it assures that only authorized persons will 

have access to vital configuration parameters. Once a Workgroup has been established, 
having an unauthorized person access these parameters could result in a catastrophic failure 
of the Workgroup and/or loss of critical data.

Perform the following procedure to assign a password to admin :

1 Highlight Administrator (admin). Click Edit . The Edit User Dialog Box will be displayed.

2 If desired, replace Administrator with the Full Name  of the actual administrator. However, it is 
strongly recommended that the Login ID  remain admin.

3 Enter the desired password in the Password  field.

Note: To help maintain security, when typing in the desired password, each character will be displayed 
as an asterisk (*) in the Password  field as well as the Verify Password  field. For example, if the string 
ABC123DEF  were typed into the field, ********* would actually be displayed.

4 Enter the desired password again in the Verify Password  field.

5 Click OK.

It will now be required to enter the password whenever the Administrator (or any person 
authorized to perform Administrator duties) uses the admin  Login ID. It is strongly suggested 

that the password be stored in a secure location in the event it is forgotten or is needed by 
another person authorized to login with the admin  Login ID.

Adding a User Each Commence Server limits the number of Users that it can handle. This number is 
displayed by selecting Help  -> About...  from the Menu Bar on the ComAdmin Dialog Box. 

Figure 8-2: License information under Help - About

The maximum number of licenses available for use with this particular Server is 10, as 
indicated by the User Limit: 10  text, not including the Administrator. The administrator will 
only be able to add as many Users as this limit allows, in this case 10. The Commence 

Server is able to be upgraded to handle more Clients as necessary. Contact Commence 
Corporation for information about this upgrade procedure.

Once the number of users you have added reaches the user limit, then another copy of the 
Client Software must be purchased before any additional users may be added to the 

Workgroup.

Perform the following procedure to add a user:

1 From the Users Dialog Box, select the Add  button. The Add User Dialog Box will be displayed. 

2 Enter the following information for the user that is being added:
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Note: As soon as any character is typed into any of these fields, the button labeled OK will be 
automatically replaced by two buttons with the labels Save and Cancel .

• Enter the new user’s full name  - This is the full name of the user.

• Enter the new user’s login ID  - This is the name that will be used to login to the shared 
database. It is recommended that each user’s login ID be set to the same ID they use for logging 
into the network in order to make it easier to remember.

• Enter the new user’s Password  - [OPTIONAL] This is the password used to verify the user’s 
identity during login to the shared database. In order to maintain security, when entering the 
password, an asterisk (*) will be displayed for each character typed.

• Verify Password  - [OPTIONAL] Re–enter the password information to verify that it has been 
entered correctly. In order to maintain security, when entering the password, an asterisk (*) will be 
displayed for each character typed.

Note: It is not necessary to assign a password in order to add a user. It is, however, recommended 
that passwords be used in order to maintain database security.

3 When complete, select Save. The user will be added, and the Add User Dialog Box will be 
displayed with the single button labeled OK.

4 Repeat steps 2 and 3 for each user that is to be added to the Workgroup.

5 When all users have been added, select OK. The Users Dialog Box will be displayed showing all 
users that have been added.

Editing a User 
(Login ID or 
Password)

From time to time, it may be necessary to change information about a user, such as 
their login ID or password.

Caution: Verify that Commence is running on the affected user’s workstation, and that the Client 
copy of the Shared Database is open. Any changes made to a User’s Login ID and/or Password 
MUST sync to the User before they can take effect at the User’s workstation.

Perform the following procedure to edit the information for a user:

1 From the Users Dialog Box, highlight the user whose information is to be edited.

2 Select the Edit  button. The Edit User Dialog Box will be displayed.

3 Modify the fields that have changed. As soon as any character is typed into any of these fields, 
the button labeled OK will be automatically replaced by two buttons with the labels Save and 
Cancel .

4 Click Save when all fields have been updated.

Deleting a User If a user is no longer a member of the Commence Workgroup, delete the User Entry 
using ComAdmin .

Caution: This is the last step in the procedure for deleting a user from a Commence Workgroup. 
There are additional steps which must be completed prior to this in order to successfully and 
completely remove a user without disrupting Workgroup Operation. Refer to “A User No Longer 
Requires Access to a Shared Database” on page 55, for complete information.
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Perform the following procedure to delete a user:

1 From the Users Dialog Box, highlight the user that is to be deleted.

2 Click Delete . A message box requesting confirmation before deleting the user will be displayed.

3 Click Yes. The Users Dialog Box will be displayed, and the entry for the user that was just deleted 
will not be shown.

When a user is deleted from the Commence Workgroup, their Client Database is discon-

nected from the Server Database and will no longer receive any updates from the Server. 
The Client Database must then be deleted using the File  -> Open/Manage Database  
command from within Commence.

Databases 
The Shared Database is the master copy of Workgroup data, and is maintained by the 

Commence Server software. When a Workgroup is setup, it is done so initially with this 

database. All Clients then enroll to the Shared Database, which then copies the Shared 
Database to each Client Workstation.

A Shared Database can be added in one of two ways:

• Start with an existing database that is already defined as desired

• Add an empty database and then define objects such as categories, agents, etc.

If an empty database is used, each object that is added will need to be made shared 
manually. It is much easier and more efficient to use an existing database and make it shared 
since the existing data and objects will automatically be made shared.

Perform the following procedure to access the Databases area of ComAdmin .

1 Select the Databases  button  from the ComAdmin menu. The Database Dialog Box is 
displayed. 

This dialog box will initially display no shared databases. After adding one or more shared 
databases to the Workgroup, they will be listed under Shared Databases .

From this screen, an Administrator can add, edit, and delete Shared Databases. The 
following sections describe each of these activities.

Adding a Shared 
Database

Perform the following procedure to add a shared database:

1 From the Database Dialog box, select Add . The Add Database Dialog Box will be displayed.

2 Complete the following information for the new database:

• Name - The name of the database. This will appear across the top of the Commence Desktop when 
the database is active. The name can be up to thirty (30) characters in length, including spaces. 

• Description  - A brief description of the data that is to be maintained within this database.

• Database Location  - The path of the directory in which the Shared Database and its components will 
be resident. This is the database that will become the Server Database . This can either be the path of 
an existing database that is to become shared (recommended), or an empty, new database. DO NOT 
use a directory that is already used for other Commence files, such as the Shared LAN Directory, 
Workgroup File Directory, or Program Directory.

3 When all information for the new database is complete, click OK. This will create the Shared 
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Database.

All data and definitions in the Shared Database will be marked as shared.

If there is more than one Shared Database, more than one copy of the Server must be 
running (e.g. one Server per Shared Database.) For information on running more than 

one copy of the Server, refer to “Running Multiple Commence Instances” on page 65.

Editing a Shared 
Database

At some point, it may become necessary to relocate a shared database. To do this, the 
path to the shared database must be edited from ComAdmin .

Perform the following procedure to edit a shared database:

1 From the Database Dialog Box, highlight the database to be edited. Click Edit . The Edit 
Database Dialog Box will be displayed.

2 Make the necessary changes.

3 Click OK.

Deleting a Shared 
Database

Deleting a Shared Database removes all links between the Server Database and Client 
Databases, thus preventing them from synchronizing changes. This command does not 

delete either the Server Database or any of the Client Databases used by Commence, 
which means that each can still be opened and used as a standalone database. If any of 
these databases are to be deleted, do so by selecting the Commence Application button   -> 

Open/Manage Database  command at each respective copy of the database.

Perform the following procedure to delete a shared database:

1 From the Database Dialog Box, highlight the database that is to be deleted.

2 Click Delete .    A message box requesting confirmation before deleting the database will be 
displayed.

3 Click Yes. The Database Dialog Box will be displayed, and the entry for the database that was 
just deleted will no longer be shown.
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Appendix C: Running Multiple 
Commence Instances
The Commence server software is capable of managing more than one server database 
on the same server hardware. To do this simply run Commence again from the shortcut 
then choose a different shared database to open. When you do this you may receive a 

warning message that Commence is already running. You can confirm this is intentional by 
responding Yes to the prompt.

To run multiple copies of Commence more seamlessly, additional Windows shortcuts can 
be created on your desktop. The following command line options are recommended to 

control how Commence is launched.

• /Database  - The /Database  option defines which database Commence opens immediately upon 
its launch. For example, one shortcut can be used to open Server Database1 and a second shortcut 
can be used to open Server Database2. In the properties for each shortcut, change the Target to 
point directly to the database path. 

For example, to create a shortcut that opens the first server database when Commence launches, 
set the Target to  "c:\Program Files (x86)\Commence\Commence RM Workgroup\commence.exe" /
Database=c:\ProgramData\Commence\Commence\8.0\ServerData1 

Similarly, set the second shortcut to  "c:\Program Files (x86)\Commence\Commence RM 
Workgroup\commence.exe" /Database=c:\ProgramData\Commence\Commence\8.0\ServerData2

• /Prompt  - The /Prompt  option instructs Commence to display a list of available databases when it 
launches. The database to be opened may then be selected from this list. For example,
"c:\Program Files (x86)\Commence\Commence RM Workgroup\commence.exe" /Prompt

• /Quiet  - When one copy of Commence is running, launching an additional copy will normally 
display a warning message. Use the /Quiet  option to suppress this warning message. For example, 
"c:\Program Files (x86)\Commence\Commence RM Workgroup\commence.exe" /Quiet

Adding Command Line Options
Perform the following procedure to add a command line option:

1 From the Windows Start  Menu, select Settings  -> Taskbar .

2 Select Start Menu Programs .

3 Click on the Advanced  button.

4 Double click on the Programs  icon.

5 Double click on the Commence  folder.

6 Highlight the Commence icon.

7 Right click on the Commence icon. Select Properties .
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8 Click on the Shortcut tab.

9 Locate the Target  information. Press the End key on the keyboard to place the cursor at the end 
of the command line. Type the desired Command Line Option at the end of this line of text.

10 Click OK. The desired option(s) will take effect the next time Commence is launched.

Note: The /Quiet  option can be used in conjunction with other options. However, /Database  and /
Prompt  cannot be used simultaneously.

Running a Server and Client on the same machine
In general it is not recommended that data be modified on a regular basis from the 

Commence Server. There are a variety of reasons for this, including:

• the Server experiences frequent interruptions due to the constant syncing

• the Server is logged in as admin  which typically has full permissions

Any adding and/or modifying of data should be done from a client.

For large workgroups it is recommended that a dedicated machine run the Commence 

Server. This will guarantee that data updates are handled in a timely manner.

For smaller workgroups, it is possible to run a Commence Client on the same machine 
as the Server. In this configuration, use the Client to modify data, and allow the 
Commence Server to run in the background to perform data synchronization.

Caution: Do not reinstall the Client software from the same machine that is running the 
Commence Server. Only the procedure outlined below should be performed.

Perform the following procedure to run a Client and a Server on the same machine:

1 Install and configure the Server software.

2 Register the Client as described in “Register Clients With the Shared Database” on page 38.

3 Launch Commence, and open the shared database.

4 From the Commence Server, create a new empty database by selecting the Commence Appli-
cation button  -> Open/Manage Database  from the Menu Bar.

5 Add a command line option of /Prompt to the Commence shortcut.

6 Launch a second copy of Commence. Open the database created in step 4 above. This is a 
temporary database used during the enrollment process.

7 From the temporary database, enroll to the shared database as described in the instruction 
sheet. See “View Registration Details” on page 39.

8 Use the /Database  or /Prompt  command line option to launch the appropriate database. 
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